Modify

Opened 8 years ago

Closed 8 years ago

#9202 closed defect (duplicate)

JOSM duplicating nodes after failed upload

Reported by: brussell237@… Owned by: brussell237@…
Priority: normal Milestone:
Component: Core Version: tested
Keywords: Update failure, duplicated Cc:

Description

JOSM when an upload gets stuck (almost all the time now) and is cancelled and then the update is done again it duplicates nodes, ways, etc. Basically JOSM is a disaster for generating corruption in OSM database.

Attachments (0)

Change History (8)

comment:1 Changed 8 years ago by skyper

Always update data after stuck uploads.
Thought there are some validator tests checking for duplicates. Did you run validator ?

comment:2 Changed 8 years ago by mkoniecz

"Basically JOSM is a disaster for generating corruption in OSM database."

Note also that duplicated node/way is not an example of corrupted database, it means something else.

comment:3 Changed 8 years ago by skyper

Owner: changed from team to brussell237@…
Status: newneedinfo

comment:4 Changed 8 years ago by brussell237@…

Hi

I experimented heavily with JOSM running on my rather old Linux laptop and it always updated. The problem appears to be with the Window version. I noticed that the Linux version goes through "opening change set", "uploading", "closing" and then a post processing option that is missing on the Window version. I re-installed the latest version of JOSM for Windows but still getting the same issue of the "Uploading objects" getting stuck. In fact as I type this it is stuck on 621 objects.

It appears that the issue is with Windows JOSM rather than any network or OSM issue.

I am attempting to clean up OSM's data with lakes duplicated up to seven times!

Cheers

comment:5 Changed 8 years ago by skyper

@brussell237:

  • Please add your system information (main menu "help" -> Status Report -> Report Bug (on the bottom))
  • Could you also please give us the changeset ids of the broken uploads or at least point use to the area where this happens

Note: The .jar file should work on all systems not depending on any OS only on a java runtime environment.

Last edited 8 years ago by skyper (previous) (diff)

comment:6 in reply to:  4 Changed 8 years ago by AlfonZ

Replying to brussell237@…:

In fact as I type this it is stuck on 621 objects.

Have you tried setting Chunk size of upload requests?

comment:7 Changed 8 years ago by Don-vip

Summary: JOSM duplicating nodesJOSM duplicating nodes after failed upload

comment:8 Changed 8 years ago by Don-vip

Resolution: duplicate
Status: needinfoclosed

Closed as duplicate of #5214.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain brussell237@….
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.