Modify

Opened 6 years ago

Closed 6 years ago

Last modified 2 years ago

#9200 closed defect (fixed)

[Patch] copy&paste of tags vanished

Reported by: malenki Owned by: team
Priority: normal Milestone: 13.11
Component: Core Version: latest
Keywords: copy buffer Cc: xeen

Description

In the latest versions of JOSM the ability to copy and paste tags of an object has vanished.

Before this happened it was possible to:

  1. mark an object
  2. press ctrl-c
  3. mark an other object
  4. press ctrl-shift-v
  5. and all tags from the first marked object were pasted to the other object

Now there is only pasted $Object_type=$Object_ID, e.g.: Line 108651339

It would be nice if the old behaviour would be restored.
Additionally I don't see much sense in copypasting object types and IDs.

Attachments (0)

Change History (14)

comment:1 Changed 6 years ago by malenki

Ticket #9199 has been marked as a duplicate of this ticket.

comment:2 Changed 6 years ago by skyper

Cc: xeen added
Keywords: copy buffer added

Seems to be a regression of r6320 (#4644).

I had this problem with more than one object selected to copy of but with a single node it did work.

comment:3 Changed 6 years ago by skyper

Priority: majornormal

comment:4 Changed 6 years ago by anonymous

I won’t be able to work on this until next Thursday. I guess this falls into a stabilize-cycle, so can you please revert my patch until I can have a look at it?

comment:5 Changed 6 years ago by julianladisch

Summary: copy&paste of tags vanished[Patch] copy&paste of tags vanished

Patch = revert r6320

comment:6 Changed 6 years ago by anonymous

Ticket #9218 has been marked as a duplicate of this ticket.

comment:7 Changed 6 years ago by Schusch

Hi - I can confirm this ticket. From snapshot 6319 to 6320 it changed. copying tags from one object and trying to paste them into another object leads to copying the element number into this object ... went back to 6319.

comment:8 Changed 6 years ago by akks

It is because of buffer contents check

if (buf == null || buf.isEmpty() || buf.matches("(\\d+,)*\\d+")) {
            pasteTagsFromJOSMBuffer(selection);
        }

(\\d+,)*\\d+ no longer matches the JOSM-generated buffer string after r6320, the exact new format is unknown because of internationalization.
If we skip the buf.matches checking, then copy-pasted JOSM buffer will be ignored if any text is in buffer - we need a way to know if current text buffer is associated with JOSM object or not (currently it is done by format checking).

Last edited 6 years ago by akks (previous) (diff)

comment:9 Changed 6 years ago by akks

Resolution: fixed
Status: newclosed

In 6321/josm:

fix #9200: repair tags copy-pasting

comment:10 Changed 6 years ago by akks

It seems that no one had time to fix this before (just like me).

I did not revert the patch but disabled translation (node 1234, way 10 for all locales) and changed buffer-detection regexp to accept such text.
Be sure to change CopyAction.CLIPBOARD_REGEXP constant if the format of text changes.

comment:11 in reply to:  10 Changed 6 years ago by skyper

Replying to akks:

I did not revert the patch but disabled translation (node 1234, way 10 for all locales) and changed buffer-detection regexp to accept such text.
Be sure to change CopyAction.CLIPBOARD_REGEXP constant if the format of text changes.

Hope, this fixes all the warning spamming the terminal, too.

comment:12 Changed 6 years ago by bastiK

Ticket #9224 has been marked as a duplicate of this ticket.

comment:13 Changed 6 years ago by Don-vip

Milestone: 13.11 (6383)

comment:14 Changed 2 years ago by stoecker

Milestone: 13.11 (6383)13.11

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.