Modify

Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#9151 closed defect (duplicate)

Unable to revert changeset

Reported by: f.pelullo@… Owned by: team
Priority: normal Milestone:
Component: Plugin reverter Version: tested
Keywords: reverter Cc:

Description

What steps will reproduce the problem?

  1. Open JOSM;
  2. without download data before, try to revert this changeset: 16788268
  3. click the upload button.

What is the expected result?
the changeset was reverted

What happens instead?
JOSM display a popup error message.

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2013-09-20 01:34:27
Last Changed Author: Don-vip
Revision: 6238
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2013-09-20 00:19:19 +0200 (Fri, 20 Sep 2013)
Last Changed Rev: 6238

Identification: JOSM/1.5 (6238 it) Windows XP 32-Bit
Memory Usage: 77 MB / 989 MB (26 MB allocated, but free)
Java version: 1.7.0_40, Oracle Corporation, Java HotSpot(TM) Client VM
VM arguments: [-Xmx1024M]

Dataset consistency test:
[WARN - ZERO NODES] Way {Way id=228225922 version=2 MT nodes=[]} has zero nodes


Plugin: PicLayer (29854)
Plugin: editgpx (29854)
Plugin: geotools (29767)
Plugin: jts (29854)
Plugin: lakewalker (29854)
Plugin: log4j (29853)
Plugin: measurement (29854)
Plugin: opendata (29938)
Plugin: photo_geotagging (29854)
Plugin: reverter (29854)
Plugin: routing (29854)
Plugin: undelete (29854)
Plugin: utilsplugin2 (29854)

java.lang.NullPointerException
	at org.openstreetmap.josm.data.validation.tests.WayConnectedToArea.visit(WayConnectedToArea.java:31)
	at org.openstreetmap.josm.data.osm.Way.accept(Way.java:212)
	at org.openstreetmap.josm.data.validation.Test.visit(Test.java:144)
	at org.openstreetmap.josm.actions.upload.ValidateUploadHook.checkUpload(ValidateUploadHook.java:61)
	at org.openstreetmap.josm.actions.UploadAction.checkPreUploadConditions(UploadAction.java:197)
	at org.openstreetmap.josm.actions.UploadAction.uploadData(UploadAction.java:220)
	at org.openstreetmap.josm.actions.UploadAction.actionPerformed(UploadAction.java:270)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$200(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (4)

comment:1 Changed 6 years ago by skyper

Component: CoreCore validator
Resolution: duplicate
Status: newclosed

Closed as duplicate of #7465.

comment:2 Changed 6 years ago by Don-vip

Component: Core validatorPlugin reverter

Fixed in [o30000].

comment:3 Changed 5 years ago by Klumbumbus

Resolution: duplicatefixed

In 8042/josm:

(The changeset message doesn't reference this ticket)

comment:4 Changed 5 years ago by Klumbumbus

Resolution: fixedduplicate

Sorry. Typo in ticket number of svn commit...

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.