Modify

Opened 6 years ago

Closed 6 years ago

Last modified 2 years ago

#9091 closed defect (fixed)

No support for hashtag URL scheme

Reported by: int_ua Owned by: Don-vip
Priority: normal Milestone: 13.11
Component: Core Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. File > Open address
  2. Paste in new hashtagged URL ( http://www.openstreetmap.org/#map=17/49.52564/29.92893 )

What is the expected result?
The area opened in JOSM.

What happens instead?
URL is not recognized.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2013-09-20 01:34:27
Last Changed Author: Don-vip
Revision: 6238
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2013-09-20 00:19:19 +0200 (Fri, 20 Sep 2013)
Last Changed Rev: 6238

Identification: JOSM/1.5 (6238 uk) Linux Ubuntu 13.04
Memory Usage: 981 MB / 981 MB (872 MB allocated, but free)
Java version: 1.7.0_25, Oracle Corporation, OpenJDK Server VM
Java package: openjdk-7-jre:i386-7u25-2.3.10-1ubuntu0.13.04.2
VM arguments: [-Djava.net.preferIPv4Stack=true, -Xms1024M, -Xmx1024M]

Plugin: RoadSigns (29854)
Plugin: SimplifyArea (29854)
Plugin: buildings_tools (29854)
Plugin: continuosDownload (28565)
Plugin: terracer (29854)
Plugin: turnrestrictions (29854)

Attachments (0)

Change History (8)

comment:1 Changed 6 years ago by bastiK

Resolution: fixed
Status: newclosed

Works for me in r6243.

comment:2 Changed 6 years ago by Don-vip

Resolution: fixed
Status: closedreopened

No it doesn't, we're talking about Open Location, I'm on it right now

comment:3 Changed 6 years ago by Don-vip

Owner: changed from team to Don-vip
Status: reopenednew

comment:4 Changed 6 years ago by Don-vip

Status: newassigned

comment:5 Changed 6 years ago by Don-vip

(There's also a problem with GPX traces -> OSM server now returns compressed files for direct links...)

comment:6 Changed 6 years ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 6244/josm:

fix #9091 - rework osm/gpx download tasks - take into account recent changes from OSM server:

  • new hashtag scheme
  • GPX traces now returned as Bzip2-compressed files

comment:7 Changed 6 years ago by Don-vip

Milestone: 13.11 (6383)

comment:8 Changed 2 years ago by stoecker

Milestone: 13.11 (6383)13.11

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.