Modify

Opened 6 years ago

Closed 6 years ago

#9088 closed defect (fixed)

Can't open KMZ file (java.lang.NegativeArraySizeException)

Reported by: solitone Owned by: Don-vip
Priority: normal Milestone:
Component: Plugin opendata Version:
Keywords: Cc:

Description (last modified by Don-vip)

I get a java.lang.NegativeArraySizeException when trying to open a KMZ file.

The file was created with Oruxmaps, and contains photo waypoints.

I can open it with Google Earth.

Here's the file:
https://www.dropbox.com/s/qyg5psxuttl4q1k/Waypoints__20130920_1447.kmz

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by Don-vip

Description: modified (diff)
Status: newassigned
Summary: Can't open KMZ fileCan't open KMZ file (java.lang.NegativeArraySizeException)

Confirmed:

Caused by: java.lang.NegativeArraySizeException
	at org.openstreetmap.josm.plugins.opendata.core.io.geographic.KmzReader.parseDoc(KmzReader.java:45)
	at org.openstreetmap.josm.plugins.opendata.core.io.geographic.KmzReader.parseDataSet(KmzReader.java:40)
	at org.openstreetmap.josm.plugins.opendata.core.io.geographic.KmlKmzImporter.parseDataSet(KmlKmzImporter.java:38)

comment:2 Changed 6 years ago by Don-vip

Resolution: fixed
Status: assignedclosed

Fixed in [o29938].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.