Modify

Opened 9 years ago

Closed 3 months ago

Last modified 3 months ago

#9065 closed defect (fixed)

[Patch] incorrect selection logic

Reported by: anonymous Owned by: Gilbert54
Priority: normal Milestone:
Component: Plugin buildings_tools Version: tested
Keywords: building_tool, object selection Cc: Woazboat

Description

What steps will reproduce the problem?

  1. select an existing object (i.e. a house)
  2. create a new building nearby using the buiding plug-in

What is the expected result?

  • the previously selected object is un-selected
  • the newly created building is automatically the selected object

What happens instead?
the previously selected object remains selected, the newly created building is not selected. This is annoying as all actions still apply to the previously selected object, while logic (well, my logic...) dictates that the most recently created object has my visual focus and should be the subject of all actions until I create another new object or select another existing object.
I suppose that this is a defect in the building tool ?

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2013-08-07 01:35:24
Last Changed Author: Don-vip
Revision: 6115
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2013-08-07 00:04:24 +0200 (Wed, 07 Aug 2013)
Last Changed Rev: 6115

Identification: JOSM/1.5 (6115 en_GB) Windows 7 64-Bit
Memory Usage: 494 MB / 494 MB (211 MB allocated, but free)
Java version: 1.7.0_25, Oracle Corporation, Java HotSpot(TM) Client VM
VM arguments: [-Xms16m, -Xmx512m]
Dataset consistency test: No problems found

Plugin: buildings_tools (29778)
Plugin: download_along (29778)
Plugin: notes (0.3)
Plugin: print (29529)
Plugin: terracer (29771)
Plugin: utilsplugin2 (29771)

Attachments (1)

josm_patch_building_tools_autoselect_replace_v1.patch (4.6 KB) - added by Woazboat 6 months ago.
Patch adding a new configuration option to always replace selection with new building

Download all attachments as: .zip

Change History (8)

comment:1 Changed 8 years ago by mdk

The function exists, but i's a little bit hidden:

  • Go to menu "Data" -> "Set building size" (CTRL-ALT-B)
  • Check "Auto-select building"

comment:2 in reply to:  1 Changed 8 years ago by Gilbert54

Replying to mdk:

The function exists, but i's a little bit hidden:

  • Go to menu "Data" -> "Set building size" (CTRL-ALT-B)
  • Check "Auto-select building"

Thanks for the tip, but it doesn't work. Did you try it ?
I'm using Version 7347 on Java 1.8.0_11.

comment:3 Changed 8 years ago by mdk

Hmmm, you are (partly) right.

Indeed this option only triggers the selection of the new building, when nothing is selected. But if a building is already selected, the selection didn't change!

In my opinion it's a bug, that "Auto-select building" option is ignored, when there is already something selected!

If something is selected when drawing a new building, the building is aligned with any way segment of the already selected way. For drawing the next building, it doesn't make a (big) difference, if the first building is still selected, or the last building is newly selected, because both are aligned to each other. But for adding tags or other operations on the selected building, it makes a big difference!

Changed 6 months ago by Woazboat

Patch adding a new configuration option to always replace selection with new building

comment:4 Changed 6 months ago by Woazboat

Cc: Woazboat added
Summary: incorrect selection logic[Patch] incorrect selection logic

comment:5 Changed 6 months ago by Woazboat

I've created a patch that adds a new configuration option to always select the new building, even when there's an existing selection. Didn't want to change the default behavior as people might be used to and rely on it.

(Also changes autoselection to a proper preference setting, which fixes #19348)

Last edited 6 months ago by Woazboat (previous) (diff)

comment:6 Changed 3 months ago by taylor.smock

Resolution: fixed
Status: newclosed

In 35915/osm:

buildings_tools: fix #9065, #19348

  • #9065: Add new configuration option to always select new building
  • #19348: Add preference for autoselect setting, which used to be forgotten on

JOSM restart

patch by Woazboat

comment:7 Changed 3 months ago by taylor.smock

In 35917/osm:

building_tools (dist) for r35915/osm and r35916/osm

  • see #9065: Add new configuration option to always select new building (patch by Woazboat)
  • see #14213: "Rotate crosshair" forgets rotation after right-click drag (patch by Woazboat)
  • see #19348: Add preference for autoselect setting, which used to be forgotten on JOSM restart (patch by Woazboat)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Gilbert54.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.