Modify

Opened 8 years ago

Closed 8 years ago

#9041 closed defect (duplicate)

Loading data

Reported by: anonymous Owned by: anonymous
Priority: normal Milestone:
Component: Core notes Version: latest
Keywords: template_report Cc: iandees

Description

What steps will reproduce the problem?

  1. loading a bit of data from server using http://www.openstreetmap.org/browse/way/88352031/history

What is the expected result?
load data

What happens instead?
crash
might be the notes plugin

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2013-09-02 01:35:33
Last Changed Author: Don-vip
Revision: 6214
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2013-09-02 03:10:02 +0200 (Mon, 02 Sep 2013)
Last Changed Rev: 6214

Identification: JOSM/1.5 (6214 it) Linux Ubuntu 13.04
Memory Usage: 194 MB / 419 MB (76 MB allocated, but free)
Java version: 1.8.0-ea, Oracle Corporation, Java HotSpot(TM) Server VM

Plugin: AddrInterpolation (29854)
Plugin: FastDraw (29854)
Plugin: ImportImagePlugin (29854)
Plugin: OpeningHoursEditor (29854)
Plugin: PicLayer (29854)
Plugin: SimplifyArea (29854)
Plugin: buildings_tools (29854)
Plugin: continuosDownload (28565)
Plugin: dataimport (29854)
Plugin: download_along (29854)
Plugin: geochat (29851)
Plugin: geotools (29767)
Plugin: irsrectify (29210)
Plugin: jts (29854)
Plugin: log4j (29853)
Plugin: mapdust (29854)
Plugin: mirrored_download (29854)
Plugin: namemanager (29854)
Plugin: notes (cb146cc)
Plugin: opendata (29854)
Plugin: openstreetbugs (29854)
Plugin: print (29854)
Plugin: proj4j (29854)
Plugin: reverter (29854)
Plugin: scripting (30540)
Plugin: tageditor (29854)
Plugin: tagging-preset-tester (29864)
Plugin: terracer (29854)
Plugin: turnrestrictions (29854)
Plugin: undelete (29854)
Plugin: utilsplugin2 (29854)
Plugin: walkingpapers (29854)
Plugin: waydownloader (29908)
Plugin: wayselector (29854)
Plugin: wikipedia (29854)

java.lang.reflect.InvocationTargetException
	at java.awt.EventQueue.invokeAndWait(EventQueue.java:1301)
	at java.awt.EventQueue.invokeAndWait(EventQueue.java:1276)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:87)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:150)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:724)
Caused by: java.lang.VerifyError: Inconsistent stackmap frames at branch target 62
Exception Details:
  Location:
    org/openstreetmap/josm/plugins/notes/NotesDownloadLoop.run()V @62: dload_2
  Reason:
    Type 'org/openstreetmap/josm/data/coor/EastNorth' (current frame, locals[1]) is not assignable to 'java/awt/geom/Point2D' (stack map, locals[1])
  Current Frame:
    bci: @48
    flags: { }
    locals: { 'org/openstreetmap/josm/plugins/notes/NotesDownloadLoop', 'org/openstreetmap/josm/data/coor/EastNorth', double, double_2nd }
    stack: { 'org/openstreetmap/josm/data/coor/EastNorth' }
  Stackmap Frame:
    bci: @62
    flags: { }
    locals: { 'org/openstreetmap/josm/plugins/notes/NotesDownloadLoop', 'java/awt/geom/Point2D', double, double_2nd }
    stack: { }
  Bytecode:
    0000000: 2a59 b400 0414 000f 65b5 0004 b200 11c6
    0000010: 004b b200 11b4 0012 c600 42b2 0011 b400
    0000020: 12b6 0013 4cb2 0011 b400 12b6 0014 492b
    0000030: c600 0e2b 2ab4 0015 b600 1699 0011 282a
    0000040: b400 1767 b800 180f 979e 0011 2ab6 0019
    0000050: 2a2b b500 152a 28b5 0017 b200 1a12 1bb6
    0000060: 001c 9900 59b2 001a 121d b600 1c9a 004e
    0000070: 2ab4 001e c600 472a b400 1eb6 001f c600
    0000080: 3d2a b400 1eb6 001f b600 2099 0030 2ab4
    0000090: 0004 0994 9c00 272a b400 059a 0019 2ab4
    00000a0: 001e c600 192a b400 1eb6 0021 2a04 b500
    00000b0: 05a7 000a 2a14 0022 b500 0414 000f b800
    00000c0: 24a7 ff3f 4c2b b600 26b1               
  Exception Handler Table:
    bci [0, 196] => handler: 196
  Stackmap Table:
    same_frame(@0)
    append_frame(@62,Object[#70],Double)
    same_frame(@76)
    chop_frame(@90,2)
    same_frame_extended(@180)
    same_frame(@187)
    same_locals_1_stack_item_frame(@196,Object[#71])

	at org.openstreetmap.josm.plugins.notes.NotesPlugin.layerAdded(NotesPlugin.java:219)
	at org.openstreetmap.josm.gui.MapView.fireLayerAdded(MapView.java:175)
	at org.openstreetmap.josm.gui.MapView.addLayer(MapView.java:350)
	at org.openstreetmap.josm.Main.addLayer(Main.java:452)
	at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$DownloadTask.finish(DownloadOsmTask.java:282)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable$1.run(PleaseWaitRunnable.java:90)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:241)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:741)
	at java.awt.EventQueue.access$400(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:694)
	at java.awt.EventQueue$3.run(EventQueue.java:691)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:75)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:711)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:220)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:135)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:127)
	at java.awt.WaitDispatchSupport$2.run(WaitDispatchSupport.java:184)
	at java.awt.WaitDispatchSupport$4.run(WaitDispatchSupport.java:229)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.WaitDispatchSupport.enter(WaitDispatchSupport.java:227)
	at java.awt.Dialog.show(Dialog.java:1084)
	at java.awt.Component.show(Component.java:1656)
	at java.awt.Component.setVisible(Component.java:1608)
	at java.awt.Window.setVisible(Window.java:1014)
	at java.awt.Dialog.setVisible(Dialog.java:1005)
	at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$4.run(PleaseWaitProgressMonitor.java:172)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:251)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:741)
	at java.awt.EventQueue.access$400(EventQueue.java:97)
...<snip>...

Attachments (0)

Change History (5)

comment:1 in reply to:  description Changed 8 years ago by skyper

Cc: iandees added
Version: latest

Replying to anonymous:

Thanks for your report.

What happens instead?
crash
might be the notes plugin

Then please try without any plugins and without the notes plugins. See wiki:Help/ResetPreferences.

Java version: 1.8.0-ea, Oracle Corporation, Java HotSpot(TM) Server VM

Java-8 could also be a problem. Did you try it with a different version ?

comment:2 Changed 8 years ago by iandees

Update your notes plugin. This version is at least a couple months old.

comment:3 Changed 8 years ago by skyper

Owner: changed from team to anonymous
Status: newneedinfo

comment:4 Changed 8 years ago by Don-vip

Component: CorePlugin notes

comment:5 Changed 8 years ago by Don-vip

Resolution: duplicate
Status: needinfoclosed

Closed as duplicate of #8998.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain anonymous.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.