Modify

Opened 5 years ago

Closed 5 years ago

#8843 closed defect (duplicate)

Merge layers when downloading after opening file

Reported by: leopoldofederico@… Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description

When you open JOSM and the first step is opening a kml file, then when you download OSM data the file layer and OSM data layer get merged.

Attachments (0)

Change History (8)

comment:1 Changed 5 years ago by skyper

Ticket #8842 has been marked as a duplicate of this ticket.

comment:2 Changed 5 years ago by skyper

Owner: changed from pertile to leopoldofederico@…
Status: newneedinfo

Please, describe your problem with more details and suggest what JOSM should do instead of merging. -Thanks

Note: You can always use the checkbox in the lower left corner of any download dialog to download into a new layer.

comment:3 Changed 5 years ago by anonymous

Thank you, I haven't noted the New layer checkbox. If you first download OSM data and then you open a file, the new file opens in a new layer. I will describe de steps:

  1. Open JOSM
  2. Open a KMZ file
  3. Download data
  4. OSM data and KMZ file get merged. It should download data in a differente layer.

It's very confusing, if you don't pay attention you can easily upload changes to OSM including the KMZ file you opened. In my case I open the KMZ file where I have administrative boundaries, that KMZ file also helps me to know which area I have to download OSM data, and then I translate those lines into JOSM data, add tags, correct them, etc.

comment:4 Changed 5 years ago by skyper

Well, what is your suggestion ?

  • treat KMZ as separate type and never merge automatically ?
  • treat opened files separately and never merge automatically (could be a preference option) ?
Last edited 5 years ago by skyper (previous) (diff)

comment:5 Changed 5 years ago by skyper

Forgot: there is a hidden feature to prohibit JOSM to upload files (upload=false). I am not sure if it only works with OSM data files though.

comment:6 Changed 5 years ago by anonymous

Treat KMZ as separate type and never merge automatically.

comment:7 Changed 5 years ago by skyper

Owner: changed from leopoldofederico@… to team
Status: needinfonew

comment:8 Changed 5 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #8039.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.