Modify

Opened 8 years ago

Closed 5 years ago

Last modified 13 months ago

#8824 closed defect (fixed)

Cancel download on broken connection does not work

Reported by: skyper Owned by: team
Priority: minor Milestone: 16.02
Component: Core Version: latest
Keywords: cancel download time out Cc:

Description

I had routing problems and did not get any connection but JOSM did not stop trying to open a connection by clicking on cancel.

GET http://api.openstreetmap.org/api/capabilities...

I have to wait for the connection time out.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2013-06-26 01:35:20
Last Changed Author: akks
Revision: 6023
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2013-06-25 14:27:11 +0200 (Tue, 25 Jun 2013)
Last Changed Rev: 6023

Identification: JOSM/1.5 (6023 en) Linux Debian GNU/Linux 7.1 (wheezy)
Memory Usage: 152 MB / 592 MB (31 MB allocated, but free)
Java version: 1.6.0_27, Sun Microsystems Inc., OpenJDK 64-Bit Server VM
Dataset consistency test: No problems found

Attachments (0)

Change History (8)

comment:1 Changed 8 years ago by skyper

Priority: normalminor

comment:2 Changed 8 years ago by rickmastfan67

See #8274.

comment:3 Changed 5 years ago by simon04

In 9411/josm:

see #8824 - Allow to cancel download of style/preset list in preferences

comment:4 Changed 5 years ago by simon04

In 9412/josm:

see #8824 - Allow to cancel updating of imagery entries in the preferences

comment:5 Changed 5 years ago by simon04

In 9414/josm:

see #8824 - Fail fast when initializing imagery entries while starting

Use a short HTTP connect timeout of 1s for fetching the entries

comment:6 Changed 5 years ago by simon04

Milestone: 16.02
Resolution: fixed
Status: newclosed

For the capabilities we have a fast fail since r3993.

Please report further non-cancelable HTTP requests.

comment:7 Changed 5 years ago by stoecker

1 second seems VERY fast to me. A small delay in name resolving or similar issues will cause a fail.

Last edited 5 years ago by stoecker (previous) (diff)

comment:8 Changed 13 months ago by simon04

Ticket #10237 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.