Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#8792 closed defect (fixed)

"Save as" window cancels/closes completely if you forget to type .osm

Reported by: pendluuum Owned by: team
Priority: minor Milestone:
Component: Core Version: tested
Keywords: save Cc:

Description

tested with: JOSM 5990

"Save as" window cancels/closes completely if you forget to type .osm.

  • Enter a file name with "." in it without .osm at the end ("Added stuff. Needs still work")
  • hit enter

result: error message (no export function found), "save as" window closes. Annoying because you have to type the desired name again.

Should be: error message which suggests the user to add .osm at the end (since that would also be the default if you use a file name without a "." in it), "save as" window stays open with the previously entered name (so the user can correct the name).

Attachments (0)

Change History (4)

comment:1 Changed 6 years ago by Manu1400

Reproductible : yes (tested on Windows)

comment:2 Changed 6 years ago by Don-vip

Can you please post your system info (help -> status report), both of you ? Thanks.

Last edited 6 years ago by Don-vip (previous) (diff)

comment:3 Changed 6 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 6011/josm:

fix #8792 - correct save of file containing a dot in their name, without extension

comment:4 Changed 6 years ago by pendluuum

@Don-vip: thanks, that works fine (tested version 6016). Other use cases in the "save as" seem also to still work. :-)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.