Modify

Opened 7 years ago

Closed 7 years ago

#8767 closed defect (duplicate)

DataIntegrityProblemException: Primitive must be part of the dataset

Reported by: naoliv Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

Clicked to add a new node and got this:

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2013-06-05 01:34:49
Last Changed Author: Don-vip
Revision: 5990
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2013-06-05 00:52:58 +0200 (Wed, 05 Jun 2013)
Last Changed Rev: 5990

Identification: JOSM/1.5 (5990 pt_BR) Linux Debian GNU/Linux testing (jessie)
Memory Usage: 179 MB / 1667 MB (7 MB allocated, but free)
Java version: 1.7.0_21, Oracle Corporation, OpenJDK 64-Bit Server VM
VM arguments: [-Djava.net.useSystemProxies=true, -Dawt.useSystemAAFontSettings=on]
Dataset consistency test: No problems found

Plugin: PicLayer (29601)
Plugin: SimplifyArea (29435)
Plugin: buildings_tools (29596)
Plugin: contourmerge (1003)
Plugin: editgpx (29596)
Plugin: geotools (29435)
Plugin: jts (29613)
Plugin: log4j (29435)
Plugin: merge-overlap (29435)
Plugin: opendata (29505)
Plugin: reverter (29561)
Plugin: scripting (30400)
Plugin: turnrestrictions (29435)
Plugin: utilsplugin2 (29615)

org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Node id=-12020 version=0 MV lat=-21.77863349055668,lon=-48.179482356696866}
	at org.openstreetmap.josm.data.osm.OsmPrimitive.checkDataset(OsmPrimitive.java:333)
	at org.openstreetmap.josm.data.osm.OsmPrimitive.getReferrers(OsmPrimitive.java:947)
	at org.openstreetmap.josm.data.osm.OsmPrimitive.getReferrers(OsmPrimitive.java:968)
	at org.openstreetmap.josm.actions.mapmode.DrawAction.getWayForNode(DrawAction.java:949)
	at org.openstreetmap.josm.actions.mapmode.DrawAction.redrawIfRequired(DrawAction.java:182)
	at org.openstreetmap.josm.actions.mapmode.DrawAction.addHighlighting(DrawAction.java:1107)
	at org.openstreetmap.josm.actions.mapmode.DrawAction.mouseMoved(DrawAction.java:772)
	at java.awt.AWTEventMulticaster.mouseMoved(AWTEventMulticaster.java:330)
	at java.awt.Component.processMouseMotionEvent(Component.java:6550)
	at javax.swing.JComponent.processMouseMotionEvent(JComponent.java:3330)
	at java.awt.Component.processEvent(Component.java:6274)
	at java.awt.Container.processEvent(Container.java:2229)
	at java.awt.Component.dispatchEventImpl(Component.java:4861)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4687)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4505)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
	at java.awt.Container.dispatchEventImpl(Container.java:2273)
	at java.awt.Window.dispatchEventImpl(Window.java:2719)
	at java.awt.Component.dispatchEvent(Component.java:4687)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:729)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:688)
	at java.awt.EventQueue$3.run(EventQueue.java:686)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:702)
	at java.awt.EventQueue$4.run(EventQueue.java:700)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:699)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

Attachments (0)

Change History (2)

comment:1 Changed 7 years ago by naoliv

Summary: Repository Root: http://josm.openstreetmap.de/svn Build-Date: 2013-06-05 01:34:49 Last Changed Author: Don-vip Revision: 5990 Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b URL: http://josm.openstreetmap.de/svn/trunk Last Changed Date: 2013-06-05 00:52:58 +0200 (Wed, 05 Jun 2013) Last Changed Rev: 5990 Identification: JOSM/1.5 (5990 pt_BR) Linux Debian GNU/Linux testing (jessie) Memory Usage: 179 MB / 1667 MB (7 MB allocated, but free) Java version: 1.7.0_21, Oracle Corporation, OpenJDK 64-Bit Server VM VM arguments: [-Djava.net.useSystemProxies=true, -Dawt.useSystemAAFontSettings=on] Dataset consistency test: No problems found Plugin: PicLayer (29601) Plugin: SimplifyArea (29435) Plugin: buildings_tools (29596) Plugin: contourmerge (1003) Plugin: editgpx (29596) Plugin: geotools (29435) Plugin: jts (29613) Plugin: log4j (29435) Plugin: merge-overlap (29435) Plugin: opendata (29505) Plugin: reverter (29561) Plugin: scripting (30400) Plugin: turnrestrictions (29435) Plugin: utilsplugin2 (29615) org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Node id=-12020 version=0 MV lat=-21.77863349055668,lon=-48.179482356696866} at org.openstreetmap.josm.data.osm.OsmPrimitive.checkDataset(OsmPrimitive.java:333) at org.openstreetmap.josm.data.osm.OsmPrimitive.getReferrers(OsmPrimitive.java:947) at org.openstreetmap.josm.data.osm.OsmPrimitive.getReferrers(OsmPrimitive.java:968) at org.openstreetmap.josm.actions.mapmode.DrawAction.getWayForNode(DrawAction.java:949) at org.openstreetmap.josm.actions.mapmode.DrawAction.redrawIfRequired(DrawAction.java:182) at org.openstreetmap.josm.actions.mapmode.DrawAction.addHighlighting(DrawAction.java:1107) at org.openstreetmap.josm.actions.mapmode.DrawAction.mouseMoved(DrawAction.java:772) at java.awt.AWTEventMulticaster.mouseMoved(AWTEventMulticaster.java:330) at java.awt.Component.processMouseMotionEvent(Component.java:6550) at javax.swing.JComponent.processMouseMotionEvent(JComponent.java:3330) at java.awt.Component.processEvent(Component.java:6274) at java.awt.Container.processEvent(Container.java:2229) at java.awt.Component.dispatchEventImpl(Component.java:4861) at java.awt.Container.dispatchEventImpl(Container.java:2287) at java.awt.Component.dispatchEvent(Component.java:4687) at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832) at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4505) at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422) at java.awt.Container.dispatchEventImpl(Container.java:2273) at java.awt.Window.dispatchEventImpl(Window.java:2719) at java.awt.Component.dispatchEvent(Component.java:4687) at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:729) at java.awt.EventQueue.access$200(EventQueue.java:103) at java.awt.EventQueue$3.run(EventQueue.java:688) at java.awt.EventQueue$3.run(EventQueue.java:686) at java.security.AccessController.doPrivileged(Native Method) at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76) at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87) at java.awt.EventQueue$4.run(EventQueue.java:702) at java.awt.EventQueue$4.run(EventQueue.java:700) at java.security.AccessController.doPrivileged(Native Method) at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76) at java.awt.EventQueue.dispatchEvent(EventQueue.java:699) at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242) at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161) at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150) at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146) at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138) at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)DataIntegrityProblemException: Primitive must be part of the dataset

comment:2 Changed 7 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #7170.
Can you please describe in #7170 what you did and attach your .osm file ? Thanks.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.