Modify

Opened 10 years ago

Closed 10 years ago

#8739 closed defect (duplicate)

JOSM.app for MacOS X does not work with Java 7

Reported by: hanno.wirth@… Owned by: Radfahrer
Priority: normal Milestone:
Component: Installer MacOS Version: tested
Keywords: java7 Cc:

Description

When starting the current JOSM.app version (5939) on MacOS X 10.8, the splash screen shows a warning that JOSM will soon stop to work with Java 6. After removing Java 6 from MacOS X and installing Java 7, JOSM.app will not run anymore. Instead, a request to install Java 6 is shown. Manually running "josm-tested.jar" from a command line in Terminal still works with Java 7.

Attachments (0)

Change History (4)

comment:1 Changed 10 years ago by Don-vip

Component: CoreInstaller MacOS
Keywords: java7 added
Owner: changed from team to Radfahrer

comment:2 Changed 10 years ago by hanno.wirth@…

In case I can help (testing, compiling etc.), please let me know.

comment:3 Changed 10 years ago by Lesath

A quick and dirty version is to execute the jar direct via
e.g.

java -jar /Applications/JOSM.app/Contents/Resources/Java/josm-snapshot-5315.jar

I don't know if the java apps are supported any longer or if the java 7 integration in Mac OS X 10.8 provided by Oracle does get better...

Just in short: JOSM works a bit slower in Java 7 under Mac OS X 10.8, but it works. It just lacks of integration into .app files.

comment:4 Changed 10 years ago by stoecker

Resolution: duplicate
Status: newclosed

Closed as duplicate of #8654.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Radfahrer.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.