Modify

Opened 10 years ago

Closed 10 years ago

#8729 closed defect (duplicate)

text transfer in search window fails

Reported by: seichter Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. open search window (ctrl-f)
  2. click on one of the fields below search window to transfer text to search field

What is the expected result?
text (eg. type:way) ist transfered to search field (uppermost line)
What happens instead?
error message
Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2013-05-08 01:34:29
Last Changed Author: stoecker
Revision: 5939
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2013-05-07 14:05:08 +0200 (Tue, 07 May 2013)
Last Changed Rev: 5939

Identification: JOSM/1.5 (5939 de) Windows 7 64-Bit
Memory Usage: 355 MB / 455 MB (185 MB allocated, but free)
Java version: 1.7.0_03, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Xms16m, -Xmx512m]
Program arguments: [N:\Tracks\_neu\N_2013-05-20_R.gpx, N:\Tracks\_neu\V_13052000.gpx, N:\Tracks\_neu\cGPS_2013-05-20_09-00.gpx, N:\Tracks\_neu\VOX00502.WAV, N:\Tracks\_neu\VOX00503.WAV, N:\Tracks\_neu\VOX00504.WAV, N:\Tracks\_neu\VOX00505.WAV, N:\Tracks\_neu\W_20.05.2013_09_05_06.gpx, N:\Tracks\_neu\mH_2013-05-20-Rad.gpx, N:\Tracks\_neu\G_2013-05-20-Rad.gpx, N:\Tracks\_neu\Q_2013-05-20-Rad.gpx]
Dataset consistency test: No problems found

Plugin: DirectDownload (29435)
Plugin: DirectUpload (29435)
Plugin: FastDraw (29532)
Plugin: FixAddresses (29519)
Plugin: ImportImagePlugin (29531)
Plugin: PicLayer (29531)
Plugin: RoadSigns (29435)
Plugin: SimplifyArea (29435)
Plugin: alignways (29435)
Plugin: buildings_tools (29435)
Plugin: continuosDownload (28565)
Plugin: contourmerge (1003)
Plugin: dataimport (29435)
Plugin: download_along (29435)
Plugin: geotools (29435)
Plugin: gpsblam (29435)
Plugin: imageryadjust (29435)
Plugin: jts (29435)
Plugin: log4j (29435)
Plugin: mapdust (29525)
Plugin: measurement (29545)
Plugin: merge-overlap (29435)
Plugin: mirrored_download (29505)
Plugin: multipoly-convert (29435)
Plugin: opendata (29505)
Plugin: openstreetbugs (29435)
Plugin: openvisible (29435)
Plugin: pdfimport (29435)
Plugin: public_transport (29435)
Plugin: reltoolbox (29535)
Plugin: reverter (29561)
Plugin: routes (29435)
Plugin: tageditor (29435)
Plugin: terracer (29509)
Plugin: turnlanes (29435)
Plugin: turnrestrictions (29435)
Plugin: undelete (29555)
Plugin: utilsplugin2 (29435)
Plugin: waydownloader (29435)
Plugin: wayselector (29435)
Plugin: wikipedia (29523)

java.lang.ClassCastException: javax.swing.plaf.basic.BasicComboBoxEditor$BorderlessTextField cannot be cast to org.openstreetmap.josm.gui.widgets.JosmTextField
	at org.openstreetmap.josm.actions.search.SearchAction$SearchKeywordRow$1.mouseClicked(SearchAction.java:196)
	at java.awt.AWTEventMulticaster.mouseClicked(AWTEventMulticaster.java:270)
	at java.awt.Component.processMouseEvent(Component.java:6508)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3321)
	at java.awt.Component.processEvent(Component.java:6270)
	at java.awt.Container.processEvent(Container.java:2229)
	at java.awt.Component.dispatchEventImpl(Component.java:4861)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4687)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4501)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
	at java.awt.Container.dispatchEventImpl(Container.java:2273)
	at java.awt.Window.dispatchEventImpl(Window.java:2713)
	at java.awt.Component.dispatchEvent(Component.java:4687)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:707)
	at java.awt.EventQueue.access$000(EventQueue.java:101)
	at java.awt.EventQueue$3.run(EventQueue.java:666)
	at java.awt.EventQueue$3.run(EventQueue.java:664)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:680)
	at java.awt.EventQueue$4.run(EventQueue.java:678)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:677)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:211)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:128)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:121)
	at java.awt.WaitDispatchSupport$2.run(WaitDispatchSupport.java:182)
	at java.awt.WaitDispatchSupport$4.run(WaitDispatchSupport.java:221)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.WaitDispatchSupport.enter(WaitDispatchSupport.java:219)
	at java.awt.Dialog.show(Dialog.java:1072)
	at java.awt.Component.show(Component.java:1651)
	at java.awt.Component.setVisible(Component.java:1603)
	at java.awt.Window.setVisible(Window.java:1013)
	at java.awt.Dialog.setVisible(Dialog.java:1003)
	at 

Attachments (0)

Change History (1)

comment:1 Changed 10 years ago by skyper

Resolution: duplicate
Status: newclosed

Closed as duplicate of #8693.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.