Modify

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8685 closed defect (fixed)

No browser for internal links from StartupPage

Reported by: skyper Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: startup page Cc: stoecker

Description

The internal links from StartupPage do not open in a browser. I got following error on the console:

Warning: Desktop class failed. Platform dependent fall back for open url in browser.
Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2013-05-06 01:34:24
Last Changed Author: Don-vip
Revision: 5932
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2013-05-06 02:53:50 +0200 (Mon, 06 May 2013)
Last Changed Rev: 5932

Identification: JOSM/1.5 (5932 de) Linux Debian GNU/Linux 7.0 (wheezy)
Memory Usage: 97 MB / 592 MB (60 MB allocated, but free)
Java version: 1.6.0_27, Sun Microsystems Inc., OpenJDK 64-Bit Server VM

This happens with gnome3 and with xdg default-web-browser, x-www-browser and gnome-www-browser all set to iceweasel.

Only the link to external websites and with full URL (http://josm.openstreetmap.de/*) work.

Attachments (0)

Change History (11)

comment:1 Changed 7 years ago by Don-vip

Summary: No browser for internal links from StartupPage (Gnome 3)No browser for internal links from StartupPage

Same on Windows. The url does not contain protocol and host.

comment:2 Changed 7 years ago by Don-vip

Cc: stoecker added

Works with r5914, not with r5916. Then caused by r5915.

comment:3 Changed 7 years ago by stoecker

Needs readding

.replaceAll("href=\"/", "href=\"" + baseurl + "/")

in wiki reader. Seems baseurl only works for images.

comment:4 Changed 7 years ago by Don-vip

Hum, readding this statement "as it" breaks the help system badly.

EDIT: no it seems already broken: when we click on Table of Contents -> Getting Started in the help index, the front page of JOSM website is displayed.

EDIT2: this kind of URL is produced: http://josm.openstreetmap.de#GettingStarted

EDIT3: External URLS are not loaded:

INFO: URL event: http://wiki.openstreetmap.org/wiki/JOSM
INFO: help topic: null
INFO: <html><base href="http://josm.openstreetmap.de"> </html>
Last edited 7 years ago by Don-vip (previous) (diff)

comment:5 Changed 7 years ago by stoecker

Resolution: fixed
Status: newclosed

In 5936/josm:

fix #8685 - wiki browser links not working

comment:6 Changed 7 years ago by stoecker

Resolution: fixed
Status: closedreopened

comment:7 Changed 7 years ago by stoecker

Hmpf, Couldn't you add last comment some seconds earlier.

comment:8 Changed 7 years ago by Don-vip

External URLs did not work before, that's not a regression :)

comment:9 Changed 7 years ago by stoecker

Resolution: fixed
Status: reopenedclosed

In 5937/josm:

fix #8685 - wiki browser fix external links (althought they look very ugly)

comment:10 Changed 7 years ago by Don-vip

In 5938/josm:

see #8685 - fix fragments handling

comment:11 Changed 7 years ago by Don-vip

Thanks, it works perfectly now :)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.