Modify

Opened 7 years ago

Closed 6 years ago

#8672 closed defect (fixed)

Plugin Todo list: buttons are not visible

Reported by: didier2020 Owned by: Gnonthgol
Priority: normal Milestone:
Component: Plugin todo Version:
Keywords: github Cc: brycenesbitt

Description (last modified by Don-vip)

if todo list is not active (no windows)
and
I use validator
=> when I active todo list plugin, the windows appears but without any visible button:


if todo list is active (windows visible)
and
I use validator
=> all is correct

Attachments (2)

Capture-8.png (21.0 KB) - added by didier2020 7 years ago.
Capture-5.png (38.5 KB) - added by didier2020 6 years ago.
error on loading

Download all attachments as: .zip

Change History (18)

Changed 7 years ago by didier2020

Attachment: Capture-8.png added

comment:1 Changed 7 years ago by AndrewBuck

I have noticed this bug myself. I am not sure if the validator causes it, I think that is unrelated, but I will try to watch for it to see if it is somehow related.

comment:2 Changed 7 years ago by stoecker

Maybe todo uses equal class name or description as validator and thus uses validator GUI settings?

comment:3 Changed 7 years ago by AndrewBuck

Ahh, this is something to look into. When Gnonthgol originally created the codebase for TODO I think he started by copying the validator codebase and then we modified it from there. So there could easily be some kind of duplicated name left over from that. Thanks for the tip stoecker.

comment:4 Changed 7 years ago by Don-vip

Ticket #8790 has been marked as a duplicate of this ticket.

comment:5 Changed 7 years ago by Don-vip

Cc: brycenesbitt added

comment:6 Changed 7 years ago by Don-vip

Description: modified (diff)
Summary: Plugin Todo list vs validatorPlugin Todo list vs validator: buttons are not visible

comment:7 Changed 7 years ago by brycenesbitt

In ticket #8790, this happens without validator.

comment:8 Changed 7 years ago by Don-vip

Summary: Plugin Todo list vs validator: buttons are not visiblePlugin Todo list: buttons are not visible

comment:9 Changed 7 years ago by Don-vip

Keywords: github added

comment:10 Changed 6 years ago by Don-vip

I have found how to fix this bug, but my PR isn't merged yet:
https://github.com/Gnonthgol/JOSM-todo/pull/7

comment:11 Changed 6 years ago by anonymous

+1 for the fix... this really impacts a very useful plugin.

comment:12 Changed 6 years ago by Gnonthgol

Merged, tested and released. Thank you very much Don-vip.

comment:13 Changed 6 years ago by Gnonthgol

Resolution: fixed
Status: newclosed

comment:14 Changed 6 years ago by didier2020

Resolution: fixed
Status: closedreopened

josm ask me to update this plugin, since i can't load the plugin : error on starting josm.
i've tested with josm tested and latest, (delete .josm )

Changed 6 years ago by didier2020

Attachment: Capture-5.png added

error on loading

comment:15 Changed 6 years ago by didier2020

sorry, it can be closed : the plugin is ok with java 7 ( my java is 6...)

comment:16 Changed 6 years ago by Don-vip

Resolution: fixed
Status: reopenedclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Gnonthgol.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.