Modify

Opened 6 years ago

Closed 6 years ago

#8650 closed enhancement (fixed)

Versioned Releases / Backwards compatibility

Reported by: fnatter@… Owned by: The111
Priority: normal Milestone:
Component: JMapViewer Version:
Keywords: Cc:

Description (last modified by Don-vip)

hi,

thanks for JMapViewer, we're happily using it in the Freeplane project :-)

I am also involved in creating Debian packages for Freeplane and JMapViewer, and our concern is:
Could you consider making JMapViewer releases with version numbers? That would make the Debian packaging easier / more meaningful. Also, we could use version gaps to express that backwards compatibility could be broken.

That would be important for the Freeplane package (and others): When a Debian packager sees that JMapViewer was updated from say 1.0 to 2.0 (and he/she finds out after correspondence with you that it is not backwards-compatible) then he/she can create a new "jmapviewer2" package that does not interfere with the current "jmapviewer" that is used by Freeplane.

Thanks!

Best Regards,
Felix

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by Don-vip

Description: modified (diff)
Type: defectenhancement

comment:2 Changed 6 years ago by The111

Resolution: fixed
Status: newclosed

I incorporated the patch from #8747 (see further comments there) in [o29618]. Now the "version numbers" of all release files will be the (previous) SVN revision. I hope this helps.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain The111.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.