Modify

Opened 6 years ago

Closed 6 years ago

#8618 closed defect (fixed)

Wikipedia plugin: http url when adding names leads to exception

Reported by: akks Owned by: simon04
Priority: normal Milestone:
Component: Plugin wikipedia Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Install wikipedia plugin
  2. Download and select object with http Wikipedia link, like http://www.openstreetmap.org/browse/way/95782139
  3. Tools / get names from Wikipedia

What is the expected result?
Add names or say about unsupported/deprecated url in wikipedia tag

What happens instead? Exception:

Build-Date: 2013-04-18 19:20:12
Revision: 5879
Is-Local-Build: true

Identification: JOSM/1.5 (5879 SVN ru) Windows 7 64-Bit
Memory Usage: 164 MB / 910 MB (40 MB allocated, but free)
Java version: 1.7.0_17, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugin: FastDraw (29457)
Plugin: ImageryCache (29484)
Plugin: InfoMode (29435)
Plugin: buildings_tools (29435)
Plugin: imagery_offset_db (29467)
Plugin: measurement (29435)
Plugin: mirrored_download (29505)
Plugin: reltoolbox (29459)
Plugin: reverter (29503)
Plugin: todo (29155)
Plugin: utilsplugin2 (29435)
Plugin: wikipedia (29435)

java.lang.RuntimeException: java.io.IOException: Server returned HTTP response code: 503 for URL: http://http.wikipedia.org/w/api.php?action=query&prop=langlinks&titles=%2F%2Fen.wikipedia.org%2Fwiki%2FNelson%2527s_Column&lllimit=500&format=xml
	at org.wikipedia.WikipediaApp.getInterwikiArticles(WikipediaApp.java:193)
	at org.wikipedia.WikipediaAddNamesAction.actionPerformed(WikipediaAddNamesAction.java:30)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2018)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2341)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.AbstractButton.doClick(AbstractButton.java:376)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:833)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:877)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.Component.processMouseEvent(Component.java:6505)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3321)
	at java.awt.Component.processEvent(Component.java:6270)
	at java.awt.Container.processEvent(Container.java:2229)
	at java.awt.Component.dispatchEventImpl(Component.java:4861)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4687)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4492)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
	at java.awt.Container.dispatchEventImpl(Container.java:2273)
	at java.awt.Window.dispatchEventImpl(Window.java:2719)
	at java.awt.Component.dispatchEvent(Component.java:4687)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:729)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:688)
	at java.awt.EventQueue$3.run(EventQueue.java:686)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:702)
	at java.awt.EventQueue$4.run(EventQueue.java:700)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:699)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)
Caused by: java.io.IOException: Server returned HTTP response code: 503 for URL: http://http.wikipedia.org/w/api.php?action=query&prop=langlinks&titles=%2F%2Fen.wikipedia.org%2Fwiki%2FNelson%2527s_Column&lllimit=500&format=xml
	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1625)
	at java.net.URL.openStream(URL.java:1037)
	at org.wikipedia.WikipediaApp.getInterwikiArticles(WikipediaApp.java:184)
	... 40 more

Attachments (0)

Change History (4)

comment:1 Changed 6 years ago by Don-vip

Component: CorePlugin wikipedia
Owner: changed from team to simon04

comment:2 Changed 6 years ago by simon04

Did you set up a Wikipedia language?

comment:3 Changed 6 years ago by akks

No, but it seems it was detected automatically.

I loaded center of London (near plcace point) for testing, object with en:... tags is processed correctly (Trafalgar square, is I remember) but
Nelson column monument contain full url in wikipedia tag (which is wrong?) and the plugin gives the exception.

comment:4 Changed 6 years ago by simon04

Resolution: fixed
Status: newclosed

Thanks for the bug report!

Fixed in [o29521], [o29522].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain simon04.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.