Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#8607 closed defect (duplicate)

Import Image plugin error

Reported by: natvander@… Owned by: team
Priority: normal Milestone:
Component: Plugin Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Open JOSM
  2. Click File/import image
  3. Import image fails to work

What is the expected result?
Import image imports geo referenced image into JOSM.

What happens instead?
Unexpected exception error pop-up.

Please provide any additional information below. Attach a screenshot if
possible.
Import image plugin has worked in previous versions of JOSM tested apart from the current and previous versions.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2013-04-09 01:34:26
Last Changed Author: stoecker
Revision: 5836
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2013-04-07 23:18:22 +0200 (Sun, 07 Apr 2013)
Last Changed Rev: 5836

Identification: JOSM/1.5 (5836 en_AU) Windows 7
Memory Usage: 181 MB / 247 MB (72 MB allocated, but free)
Java version: 1.7.0_17, Oracle Corporation, Java HotSpot(TM) Client VM
Operating system: Windows 7
Dataset consistency test: No problems found

Plugin: ImportImagePlugin (29435)
Plugin: PicLayer (29435)
Plugin: buildings_tools (29435)
Plugin: dataimport (29435)
Plugin: geotools (29435)
Plugin: jts (29435)
Plugin: log4j (29435)
Plugin: multipoly-convert (29435)
Plugin: terracer (29435)
Plugin: utilsplugin2 (29435)

java.lang.ExceptionInInitializerError
	at org.openstreetmap.josm.plugins.ImportImagePlugin.ImageLayer.createImage(ImageLayer.java:153)
	at org.openstreetmap.josm.plugins.ImportImagePlugin.ImageLayer.<init>(ImageLayer.java:76)
	at org.openstreetmap.josm.plugins.ImportImagePlugin.LoadImageAction.actionPerformed(LoadImageAction.java:47)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.AbstractButton.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$200(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)
Caused by: java.lang.IllegalArgumentException: Can't load standard profile: PYCC.pf
	at java.awt.color.ICC_Profile.getInstance(Unknown Source)
	at java.awt.color.ColorSpace.getInstance(Unknown Source)
	at org.geotools.image.ImageWorker.<clinit>(ImageWorker.java:136)
	... 42 more

Attachments (0)

Change History (2)

comment:1 Changed 8 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #8583.

comment:2 Changed 8 years ago by skyper

Maybe it is a problem with 32 bit vs. 64 bit (see ticket:8513#comment:4).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.