Modify

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8582 closed defect (fixed)

I was correcting osm errors modify and sending this error when i try to load another element by click on web link (8111 port)

Reported by: mcheck Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description (last modified by Don-vip)

Last Changed Author: stoecker
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2013-04-07 23:18:22 +0200 (Sun, 07 Apr 2013)
Last Changed Rev: 5836
Build-Date: 2013-04-08 01:34:29
Repository Root: http://josm.openstreetmap.de/svn
Revision: 5836
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b

Identification: JOSM/1.5 (5836 it) Linux
Memory Usage: 447 MB / 931 MB (297 MB allocated, but free)
Java version: 1.8.0-ea, Oracle Corporation, Java HotSpot(TM) Server VM
Operating system: Linux
VM arguments: [-Xmx1048M]

Plugin: AddrInterpolation (29435)
Plugin: FastDraw (29457)
Plugin: FixAddresses (29435)
Plugin: HouseNumberTaggingTool (29475)
Plugin: ImportImagePlugin (29435)
Plugin: OpeningHoursEditor (29435)
Plugin: PicLayer (29435)
Plugin: RoadSigns (29435)
Plugin: SimplifyArea (29435)
Plugin: buildings_tools (29435)
Plugin: continuosDownload (28565)
Plugin: contourmerge (1003)
Plugin: dataimport (29435)
Plugin: download_along (29435)
Plugin: ext_tools (29435)
Plugin: geotools (29435)
Plugin: graphview (29435)
Plugin: imageryadjust (29435)
Plugin: importvec (29435)
Plugin: irsrectify (29210)
Plugin: jts (29435)
Plugin: lakewalker (29435)
Plugin: log4j (29435)
Plugin: mirrored_download (29435)
Plugin: multipoly-convert (29435)
Plugin: namemanager (29435)
Plugin: opendata (29435)
Plugin: openstreetbugs (29435)
Plugin: pbf (29435)
Plugin: pdfimport (29435)
Plugin: photo_geotagging (29435)
Plugin: plastic_laf (29435)
Plugin: print (29435)
Plugin: proj4j (29435)
Plugin: reltoolbox (29459)
Plugin: reverter (29435)
Plugin: scripting (30300)
Plugin: tag2link (29461)
Plugin: tageditor (29435)
Plugin: tagging-preset-tester (29435)
Plugin: terracer (29435)
Plugin: utilsplugin2 (29435)
Plugin: walkingpapers (29480)
Plugin: waypoint_search (29435)
Plugin: wikipedia (29435)
Plugin: wms-turbo-challenge2 (29435)

java.lang.reflect.InvocationTargetException
	at java.awt.EventQueue.invokeAndWait(EventQueue.java:1270)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:87)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:145)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
	at java.lang.Thread.run(Thread.java:722)
Caused by: java.lang.IllegalStateException: Dialog was already created
	at org.openstreetmap.josm.gui.dialogs.LayerListDialog.createInstance(LayerListDialog.java:92)
	at org.openstreetmap.josm.gui.MapFrame.<init>(MapFrame.java:220)
	at org.openstreetmap.josm.Main.createMapFrame(Main.java:448)
	at org.openstreetmap.josm.Main.addLayer(Main.java:438)
	at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$DownloadTask.finish(DownloadOsmTask.java:274)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable$1.run(PleaseWaitRunnable.java:89)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:241)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:720)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:681)
	at java.awt.EventQueue$3.run(EventQueue.java:679)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:75)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:690)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:216)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:135)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:127)
	at java.awt.WaitDispatchSupport$2.run(WaitDispatchSupport.java:182)
	at java.awt.WaitDispatchSupport$4.run(WaitDispatchSupport.java:221)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.WaitDispatchSupport.enter(WaitDispatchSupport.java:219)
	at java.awt.Dialog.show(Dialog.java:1077)
	at java.awt.Component.show(Component.java:1656)
	at java.awt.Component.setVisible(Component.java:1608)
	at java.awt.Window.setVisible(Window.java:1014)
	at java.awt.Dialog.setVisible(Dialog.java:1003)
	at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$4.run(PleaseWaitProgressMonitor.java:170)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:251)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:720)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:681)
	at java.awt.EventQueue$3.run(EventQueue.java:679)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:75)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:690)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:216)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:135)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:123)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:119)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:111)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:97)

Attachments (0)

Change History (4)

comment:1 Changed 7 years ago by akks

Can you please attach the link or, if impossible, specify the page where it is placed?

comment:2 Changed 7 years ago by Don-vip

Description: modified (diff)
Reporter: changed from anonymous to mcheck

comment:3 Changed 7 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 5896/josm:

fix #8582 - synchronize Main.removeLayer()

comment:4 Changed 7 years ago by Don-vip

In 5897/josm:

see #8582 - Use Main.removeLayer() everywhere

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.