Modify

Opened 12 years ago

Closed 12 years ago

Last modified 3 years ago

#85 closed enhancement (wontfix)

Fill in tag created_by with OSM user name (automatically)

Reported by: anonymous Owned by: imi
Priority: major Milestone:
Component: Core Version:
Keywords: Cc:

Description

It would be great to automatically fill in (create) tag created_by with OSM user name. this would help to identify who created/changed elements.

This feature could be as option.

Attachments (0)

Change History (1)

comment:1 Changed 12 years ago by imi

Resolution: wontfix
Status: newclosed

First: created_by was not meant to be for the user name. Although you can fill in anything there, I originally introduced it to help finding problems in the dataset that occoured because of specific editors, not specific people.

Second: The origin of any data is already stored on the server. There is no point in reproducing it within properties.

Instead, the author should be moved from some special storage on the server into the properties (or the editor should be moved into the special storage).

But this is a server change (and should be reported in trac.openstreetmap.org).

If someone absolutly want to have such an feature, I think it should be done as a plugin, that hooks into upload of data and mangle the properties there.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain imi.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.