Modify

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#8453 closed defect (duplicate)

IllegalArgumentException importing image from gpx context menu

Reported by: burkhard.kirchner@… Owned by: burkhard.kirchner@…
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description (last modified by skyper)

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2013-02-22 02:31:38
Last Changed Author: Don-vip
Revision: 5740
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2013-02-21 23:58:58 +0100 (Thu, 21 Feb 2013)
Last Changed Rev: 5740

Identification: JOSM/1.5 (5740 de)
Memory Usage: 77 MB / 872 MB (11 MB allocated, but free)
Java version: 1.7.0_15, Oracle Corporation, OpenJDK Server VM
Operating system: Linux
Dataset consistency test: No problems found

Plugin: DirectDownload (29222)
Plugin: DirectUpload (29210)
Plugin: ElevationProfile (28150)
Plugin: FixAddresses (29210)
Plugin: HouseNumberTaggingTool (29210)
Plugin: OpeningHoursEditor (29210)
Plugin: RoadSigns (29232)
Plugin: TombPlugin (41)
Plugin: buildings_tools (29210)
Plugin: contourmerge (1003)
Plugin: download_along (29210)
Plugin: ext_tools (29210)
Plugin: gpxfilter (29222)
Plugin: measurement (29210)
Plugin: merge-overlap (29210)
Plugin: michigan_left (29210)
Plugin: multipoly-convert (29210)
Plugin: openvisible (29222)
Plugin: print (29210)
Plugin: public_transport (29222)
Plugin: reltoolbox (29210)
Plugin: reverter (29216)
Plugin: turnlanes (29210)
Plugin: turnrestrictions (29210)
Plugin: utilsplugin2 (29241)
Plugin: wikipedia (29218)

java.lang.IllegalArgumentException: Comparison method violates its general contract!
	at java.util.TimSort.mergeLo(TimSort.java:747)
	at java.util.TimSort.mergeAt(TimSort.java:483)
	at java.util.TimSort.mergeCollapse(TimSort.java:410)
	at java.util.TimSort.sort(TimSort.java:214)
	at java.util.TimSort.sort(TimSort.java:173)
	at java.util.Arrays.sort(Arrays.java:659)
	at java.util.Collections.sort(Collections.java:217)
	at javax.swing.SortingFocusTraversalPolicy.enumerateAndSortCycle(SortingFocusTraversalPolicy.java:136)
	at javax.swing.SortingFocusTraversalPolicy.getFocusTraversalCycle(SortingFocusTraversalPolicy.java:110)
	at javax.swing.SortingFocusTraversalPolicy.getComponentAfter(SortingFocusTraversalPolicy.java:280)
	at javax.swing.LayoutFocusTraversalPolicy.getComponentAfter(LayoutFocusTraversalPolicy.java:106)
	at java.awt.Component.getNextFocusCandidate(Component.java:7860)
	at java.awt.DefaultKeyboardFocusManager.doRestoreFocus(DefaultKeyboardFocusManager.java:171)
	at java.awt.DefaultKeyboardFocusManager.restoreFocus(DefaultKeyboardFocusManager.java:151)
	at java.awt.DefaultKeyboardFocusManager.restoreFocus(DefaultKeyboardFocusManager.java:134)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(DefaultKeyboardFocusManager.java:302)
	at java.awt.Component.dispatchEventImpl(Component.java:4731)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Window.dispatchEventImpl(Window.java:2719)
	at java.awt.Component.dispatchEvent(Component.java:4687)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:729)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:688)
	at java.awt.EventQueue$3.run(EventQueue.java:686)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:702)
	at java.awt.EventQueue$4.run(EventQueue.java:700)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:699)
	at java.awt.SequencedEvent.dispatch(SequencedEvent.java:128)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:727)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:688)
	at java.awt.EventQueue$3.run(EventQueue.java:686)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:702)
	at java.awt.EventQueue$4.run(EventQueue.java:700)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:699)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

Attachments (2)

20130223151326.gpx (102.3 KB) - added by burkhard.kirchner@… 9 years ago.
IMG_20130223_155746.jpg (289.9 KB) - added by anonymous 9 years ago.

Download all attachments as: .zip

Change History (10)

Changed 9 years ago by burkhard.kirchner@…

Attachment: 20130223151326.gpx added

Changed 9 years ago by anonymous

Attachment: IMG_20130223_155746.jpg added

comment:1 Changed 9 years ago by skyper

Description: modified (diff)
Summary: Import imagesIllegalArgumentException opening an unsupported image

Thanks for reporting.

To open an photo with GPS position data, just open it with open file (you can select several at once). Opens without problem on my system.

ImportImage Plugin is for importing satellite and aerial images as background. It is rather unmaintained and you should use Piclayer instead.

The Plugin should give a warning and no exception though.

Last edited 9 years ago by skyper (previous) (diff)

comment:2 Changed 9 years ago by anonymous

I'm sorry. That's My mistake.
Really I don't use the ImportImage plugin.
I've used the image import function: Right click on the previously loaded gpx file - import images
The reported error occurs but the geo referenced image is loaded correctly.

comment:3 Changed 9 years ago by skyper

Component: Plugin importimageCore
Summary: IllegalArgumentException opening an unsupported imageIllegalArgumentException importing image from gpx context menu

comment:4 Changed 9 years ago by Don-vip

In 5745/josm:

see #8453 - Do not consider remote .gpx files as downloaded from OSM API server

comment:5 Changed 9 years ago by Don-vip

Cannot reproduce, even after installing all your plugins.

Does it happen all the time ? If yes, can you attach your profile please ? Thanks.

comment:6 Changed 9 years ago by Don-vip

Owner: changed from team to burkhard.kirchner@…
Status: newneedinfo

comment:7 Changed 9 years ago by Don-vip

Resolution: needinfo
Status: needinfoclosed

comment:8 Changed 8 years ago by Don-vip

Resolution: needinfoduplicate

Closed as duplicate of #8712.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain burkhard.kirchner@….
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.