Modify

Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#8413 closed defect (fixed)

[Patch] Address preset not being cleared

Reported by: Cassio90 Owned by: team
Priority: normal Milestone: 14.02
Component: Core Version: tested
Keywords: address preset Cc:

Description

When using the address preset gui to fill address information, the information from a previous edit is shown in the fields.

How to reproduce:

  • Edit any building with address information using the address preset.
  • choose "Use Preset" button or whatever it's called in english. (Not "Cancel")
  • select any building with missing address information or none at all.
  • use address preset to edit the information.
  • the previous edits information is shown in the fields that should be empty.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2013-02-06 02:31:34
Last Changed Author: Don-vip
Revision: 5697
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2013-02-06 01:35:48 +0100 (Wed, 06 Feb 2013)
Last Changed Rev: 5697

Identification: JOSM/1.5 (5697 de)
Memory Usage: 118 MB / 247 MB (66 MB allocated, but free)
Java version: 1.7.0_11, Oracle Corporation, Java HotSpot(TM) Client VM
Operating system: Windows 7
Dataset consistency test: No problems found

Plugin: FixAddresses (29210)
Plugin: buildings_tools (29210)
Plugin: graphview (29210)
Plugin: measurement (29210)
Plugin: public_transport (29222)
Plugin: terracer (29210)
Plugin: utilsplugin2 (29239)

Attachments (1)

8413.patch (3.6 KB) - added by simon04 6 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 7 years ago by Don-vip

Component: unspecifiedCore

comment:2 Changed 7 years ago by simon04

Resolution: invalid
Status: newclosed

This is not a bug, this is a feature, really. The idea is to use this preset for tagging a number of houses in the same street. For this process it is handy to keep street, city, postal code filled out.

comment:3 Changed 7 years ago by Cassio90

Well then I suggest to color the fields (yellow?) to notify the user about the suggestion, or have a way to disable it completely.

It happened to me when filling out information of many incomplete addresses that all this information was added without me noticing it.
When I noticed what the preset did, half of addresses had wrong information already and I had to start over.

From then on I have been double checking every single field against the actual key/value entries to make sure all the information is correct before closing the template window. This however increases mental load and it takes more time to finish the task. I often even went back to entering the key/value pairs manually because it is safer. ;)

I see that this feature may be useful but in my case working on a country & city border, street, city, postal AND country code often change between edits.

comment:4 Changed 7 years ago by simon04

I agree that this behaviour is unwanted/harmful for fixing addresses. Some thoughts (also @team):

  • Fill in previous data only when no corresponding tags are present in object (for addresses, only fill in when no addr:* tag is present)
  • Have two presets, one with and one without fill in functionality (duplication might be confusing)
  • …?

comment:5 Changed 7 years ago by stoecker

Resolution: invalid
Status: closedreopened

Changed 6 years ago by simon04

Attachment: 8413.patch added

comment:6 Changed 6 years ago by simon04

Milestone: 14.02
Summary: Address preset not being cleared[Patch] Address preset not being cleared

Patch attached which implements first item from comment:4.

comment:7 Changed 6 years ago by simon04

Resolution: fixed
Status: reopenedclosed

In 6772/josm:

fix #8413 - Presets: no not apply use_last_as_default when calling the preset dialog on an object with some tags of this preset already set

This avoids wrongs address tags when using the address preset.

comment:8 Changed 6 years ago by aceman

Yes, I noticed this too.
So can we assume that for an object with no addr:* tags we can choose Address from the Presets menu and values will be prefilled? When on an object with addr:* tags, we can click on the Address preset in the object editor (where only matching presets are shown) and no fields will be prefilled? Is that the intended operation? I would be OK with that.

comment:9 Changed 6 years ago by simon04

Right. Notice that it doesn't make a difference whether you execute the Address preset in the object editor (where only matching presets are shown) or via the preset menu/search. So whenever an addr: tag is present, no value from the previous preset dialog is inserted.

comment:10 Changed 6 years ago by simon04

In 6795/josm:

Refactor tagging presets in order to get rid of static variable presetInitiallyMatches - see #8413

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.