Modify

Opened 6 years ago

Closed 6 years ago

#8402 closed defect (duplicate)

DataIntegrityProblemException (Primitive must be part of the dataset) when adding a node

Reported by: richlv Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: template_report Cc:

Description (last modified by Don-vip)

selected a node, pressed p, moved that node
pressed a

I might have clicked on the way to add another node or not - don't remember exactly


Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-11-29 02:31:07
Last Changed Author: stoecker
Revision: 5608
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-11-28 23:47:46 +0100 (Wed, 28 Nov 2012)
Last Changed Rev: 5608

Identification: JOSM/1.5 (5608 en)
Memory Usage: 140 MB / 682 MB (30 MB allocated, but free)
Java version: 1.6.0_24, Sun Microsystems Inc., OpenJDK 64-Bit Server VM
Operating system: Linux
Dataset consistency test: No problems found

Plugin: PicLayer (29210)
Plugin: reverter (29210)
Plugin: terracer (29037)

org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Node id=-11586 version=0 MVD lat=10.442670391140686,lon=-75.52295358473829}
	at org.openstreetmap.josm.data.osm.OsmPrimitive.checkDataset(OsmPrimitive.java:326)
	at org.openstreetmap.josm.data.osm.OsmPrimitive.getReferrers(OsmPrimitive.java:896)
	at org.openstreetmap.josm.data.osm.OsmPrimitive.getReferrers(OsmPrimitive.java:917)
	at org.openstreetmap.josm.actions.mapmode.DrawAction.getWayForNode(DrawAction.java:919)
	at org.openstreetmap.josm.actions.mapmode.DrawAction.redrawIfRequired(DrawAction.java:177)
	at org.openstreetmap.josm.actions.mapmode.DrawAction.addHighlighting(DrawAction.java:1077)
	at org.openstreetmap.josm.actions.mapmode.DrawAction.eventDispatched(DrawAction.java:285)
	at java.awt.Toolkit$SelectiveAWTEventListener.eventDispatched(Toolkit.java:2378)
	at java.awt.Toolkit$ToolkitEventMulticaster.eventDispatched(Toolkit.java:2270)
	at java.awt.Toolkit$ToolkitEventMulticaster.eventDispatched(Toolkit.java:2269)
	at java.awt.Toolkit.notifyAWTEventListeners(Toolkit.java:2228)
	at java.awt.Component.dispatchEventImpl(Component.java:4646)
	at java.awt.Container.dispatchEventImpl(Container.java:2103)
	at java.awt.Component.dispatchEvent(Component.java:4576)
	at java.awt.KeyboardFocusManager.redispatchEvent(KeyboardFocusManager.java:1895)
	at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(DefaultKeyboardFocusManager.java:769)
	at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(DefaultKeyboardFocusManager.java:1045)
	at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(DefaultKeyboardFocusManager.java:912)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(DefaultKeyboardFocusManager.java:734)
	at java.awt.Component.dispatchEventImpl(Component.java:4620)
	at java.awt.Container.dispatchEventImpl(Container.java:2103)
	at java.awt.Window.dispatchEventImpl(Window.java:2518)
	at java.awt.Component.dispatchEvent(Component.java:4576)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:672)
	at java.awt.EventQueue.access$400(EventQueue.java:96)
	at java.awt.EventQueue$2.run(EventQueue.java:631)
	at java.awt.EventQueue$2.run(EventQueue.java:629)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:116)
	at java.awt.EventQueue$3.run(EventQueue.java:645)
	at java.awt.EventQueue$3.run(EventQueue.java:643)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:642)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:194)
	at java.awt.Dialog$1.run(Dialog.java:1073)
	at java.awt.Dialog$3.run(Dialog.java:1127)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.Dialog.show(Dialog.java:1125)
	at java.awt.Component.show(Component.java:1672)
	at java.awt.Component.setVisible(Component.java:1624)
	at java.awt.Window.setVisible(Window.java:882)
	at java.awt.Dialog.setVisible(Dialog.java:1012)
	at org.openstreetmap.josm.gui.ExtendedDialog.setVisible(ExtendedDialog.java:467)
	at org.openstreetmap.josm.gui.ExtendedDialog.showDialog(ExtendedDialog.java:269)
	at org.openstreetmap.josm.tools.BugReportExceptionHandler$1.run(BugReportExceptionHandler.java:96)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:226)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:670)
	at java.awt.EventQueue.access$400(EventQueue.java:96)
	at java.awt.EventQueue$2.run(EventQueue.java:631)
	at java.awt.EventQueue$2.run(EventQueue.java:629)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:640)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:194)
	at java.awt.Dialog$1.run(Dialog.java:1073)
	at java.awt.Dialog$3.run(Dialog.java:1127)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.Dialog.show(Dialog.java:1125)
	at java.awt.Component.show(Component.java:1672)
	at java.awt.Component.setVisible(Component.java:1624)
	at java.awt.Window.setVisible(Window.java:882)
	at java.awt.Dialog.setVisible(Dialog.java:1012)
	at org.openstreetmap.josm.gui.ExtendedDialog.setVisible(ExtendedDialog.java:467)
	at org.openstreetmap.josm.gui.ExtendedDialog.showDialog(ExtendedDialog.java:269)
	at org.openstreetmap.josm.tools.BugReportExceptionHandler$1.run(BugReportExceptionHandler.java:96)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:226)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:670)
	at java.awt.EventQueue.access$400(EventQueue.java:96)
	at java.awt.EventQueue$2.run(EventQueue.java:631)
...<snip>.

Attachments (0)

Change History (3)

comment:1 Changed 6 years ago by Don-vip

Description: modified (diff)
Summary: unexpected exception when adding a nodeDataIntegrityProblemException (Primitive must be part of the dataset) when adding a node

comment:2 Changed 6 years ago by skyper

similar to #7170

comment:3 Changed 6 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #7170.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.