Modify

Opened 7 years ago

Closed 7 years ago

#8380 closed defect (fixed)

NullPointerException after way is highlighted using JOSM link from a browser

Reported by: augustus.kling@… Owned by: team
Priority: normal Milestone:
Component: Core remotecontrol Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. In a browser, goto http://tools.geofabrik.de/osmi/debug.html?view=routing&lon=-4.16669&lat=55.83564&zoom=11&opacity=0.48&overlays=unconnected_major1,unconnected_major2,unconnected_major5,unconnected_minor1,unconnected_minor2,unconnected_minor5,duplicate_ways
  2. Click the way just south of the label Bellshill
  3. The browser invokes JOSM using http://localhost:8111/load_and_zoom?left=-4.03186&bottom=55.81183&right=-4.02970&top=55.81395&select=way141521704

What is the expected result?

JOSM highlights they way.

What happens instead?

JOSM highlights they way as it should but then shows the exception. This happened only on the first try. I was unable to reproduce the issues and did never see the issue with other way either.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2013-01-25 02:31:09
Last Changed Author: stoecker
Revision: 5669
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2013-01-24 15:19:46 +0100 (Thu, 24 Jan 2013)
Last Changed Rev: 5669

Identification: JOSM/1.5 (5669 en)
Memory Usage: 212 MB / 3544 MB (57 MB allocated, but free)
Java version: 1.6.0_24, Sun Microsystems Inc., OpenJDK 64-Bit Server VM
Operating system: Linux (Ubuntu 12.04)
Dataset consistency test: No problems found

Plugin: RoadSigns (28656)
Plugin: contourmerge (1003)
Plugin: photo_geotagging (28807)
Plugin: print (28807)
Plugin: utilsplugin2 (29124)

java.lang.NullPointerException
	at javax.swing.JLabel.setIcon(JLabel.java:401)
	at org.openstreetmap.josm.gui.OsmPrimitivRenderer.renderer(OsmPrimitivRenderer.java:70)
	at org.openstreetmap.josm.gui.OsmPrimitivRenderer.getListCellRendererComponent(OsmPrimitivRenderer.java:44)
	at javax.swing.plaf.basic.BasicListUI.updateLayoutState(BasicListUI.java:1360)
	at javax.swing.plaf.basic.BasicListUI.maybeUpdateLayoutState(BasicListUI.java:1310)
	at javax.swing.plaf.basic.BasicListUI$Handler.valueChanged(BasicListUI.java:2619)
	at javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:184)
	at javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:164)
	at javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:211)
	at javax.swing.DefaultListSelectionModel.insertIndexInterval(DefaultListSelectionModel.java:632)
	at javax.swing.plaf.basic.BasicListUI$Handler.intervalAdded(BasicListUI.java:2577)
	at javax.swing.AbstractListModel.fireIntervalAdded(AbstractListModel.java:147)
	at org.openstreetmap.josm.gui.dialogs.RelationListDialog$RelationListModel.setRelations(RelationListDialog.java:730)
	at org.openstreetmap.josm.gui.dialogs.RelationListDialog.initFromLayer(RelationListDialog.java:243)
	at org.openstreetmap.josm.gui.dialogs.RelationListDialog.dataChanged(RelationListDialog.java:1004)
	at org.openstreetmap.josm.io.remotecontrol.handler.LoadAndZoomHandler$2.run(LoadAndZoomHandler.java:181)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
	at java.lang.Thread.run(Thread.java:67

Attachments (0)

Change History (4)

comment:1 Changed 7 years ago by augustus.kling@…

The same effect occurred again, this time whilst loading relation 2707931. Note that the stack trace is different than before.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2013-01-25 02:31:09
Last Changed Author: stoecker
Revision: 5669
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2013-01-24 15:19:46 +0100 (Thu, 24 Jan 2013)
Last Changed Rev: 5669

Identification: JOSM/1.5 (5669 en)
Memory Usage: 241 MB / 3544 MB (65 MB allocated, but free)
Java version: 1.6.0_24, Sun Microsystems Inc., OpenJDK 64-Bit Server VM
Operating system: Linux
Dataset consistency test: No problems found

Plugin: RoadSigns (28656)
Plugin: contourmerge (1003)
Plugin: photo_geotagging (28807)
Plugin: print (28807)
Plugin: utilsplugin2 (29124)

java.lang.NullPointerException
	at javax.swing.JLabel.setIcon(JLabel.java:401)
	at org.openstreetmap.josm.gui.OsmPrimitivRenderer.renderer(OsmPrimitivRenderer.java:70)
	at org.openstreetmap.josm.gui.OsmPrimitivRenderer.getListCellRendererComponent(OsmPrimitivRenderer.java:44)
	at javax.swing.plaf.basic.BasicListUI.updateLayoutState(BasicListUI.java:1360)
	at javax.swing.plaf.basic.BasicListUI.maybeUpdateLayoutState(BasicListUI.java:1310)
	at javax.swing.plaf.basic.BasicListUI.paintImpl(BasicListUI.java:263)
	at javax.swing.plaf.basic.BasicListUI.paint(BasicListUI.java:239)
	at javax.swing.plaf.ComponentUI.update(ComponentUI.java:161)
	at javax.swing.JComponent.paintComponent(JComponent.java:766)
	at javax.swing.JComponent.paint(JComponent.java:1030)
	at javax.swing.JComponent.paintToOffscreen(JComponent.java:5139)
	at javax.swing.BufferStrategyPaintManager.paint(BufferStrategyPaintManager.java:302)
	at javax.swing.RepaintManager.paint(RepaintManager.java:1188)
	at javax.swing.JComponent._paintImmediately(JComponent.java:5087)
	at javax.swing.JComponent.paintImmediately(JComponent.java:4897)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:783)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:735)
	at javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:677)
	at javax.swing.RepaintManager.access$700(RepaintManager.java:58)
	at javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1593)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:226)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:670)
	at java.awt.EventQueue.access$400(EventQueue.java:96)
	at java.awt.EventQueue$2.run(EventQueue.java:631)
	at java.awt.EventQueue$2.run(EventQueue.java:629)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:640)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)

comment:2 Changed 7 years ago by skyper

Component: CoreCore remotecontrol

comment:3 Changed 7 years ago by Don-vip

JOSM had the exact same problem 3 years ago: #3992
Looks like this isn't fixed.

comment:4 Changed 7 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 5862/josm:

fix #8380 - NPE in OsmPrimitivRenderer

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.