Modify

Opened 6 years ago

Closed 6 years ago

#8350 closed defect (fixed)

Copy tags from previous selection 'forgets' the tags when an untagged object is selected.

Reported by: AndrewBuck Owned by: team
Priority: normal Milestone:
Component: Plugin utilsplugin2 Version: latest
Keywords: Cc:

Description

Description

The "copy tags from previous selection" with the hotkey Shift+R will "forget" the tags it has saved if you happen to select a node or way that is untagged. It seems to be always copying the tags of any object you select into its tag buffer, even if that object has no tags, thereby clearing the buffer (i.e. replacing it with the empty tag set).

Detailed steps to reproduce

  • Select an object with some tags (call this 'object 1')
  • Select an object with no tags on it (call this 'object 2')
  • Select some new object and press Shift+R
    • You expect to get the tags from object 1 applied to this new object
    • instead what you get is no change in the tags, i.e. the tags from object 2 (the null set) are being applied

Suggested fix

Looking at the code a bit it looks like there should be some kind of "if numTags > 0" type of check added to the rememberSelectionTags() function in TagBufferAction.java

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by Don-vip

Resolution: fixed
Status: newclosed

Fixed in [o29672].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.