Modify

Opened 8 years ago

Closed 3 weeks ago

#8334 closed enhancement (fixed)

Option to select/configure font size

Reported by: naoliv Owned by: team
Priority: minor Milestone: 20.08
Component: Core Version:
Keywords: font Cc:

Description

Is it possible to have an option to configure the font size of the panels (and maybe even all the fonts) from JOSM, please?
For example, for me I would like to have a smaller font size than the current displayed size (attached).

Attachments (3)

font-size.png (16.5 KB) - added by naoliv 8 years ago.
Example of panels with current font size
8334.patch (8.2 KB) - added by Don-vip 8 years ago.
k.jpg (12.4 KB) - added by jidanni 3 years ago.
Please do something. Users of Chinese must click Edit on each item just to see what it says!

Download all attachments as: .zip

Change History (18)

Changed 8 years ago by naoliv

Attachment: font-size.png added

Example of panels with current font size

comment:1 Changed 8 years ago by Don-vip

Have you tried other look and feel? I don't like default Metal theme, and usually prefer native theme, or Nimbus. I think they use smaller fonts.

comment:2 Changed 8 years ago by naoliv

I have tried, but I don't like any of them (Nimbus, CDE/Motif nor GTK+; Metal is the one that I like).
I still prefer to have customizable font size (it will also allow people to have a different font size (and font family maybe?) on other themes).

comment:3 Changed 8 years ago by stoecker

You can configure the map font in advanced prefs. I think for others (menu, ...) there will be a java property which modifies them. We don't set it in JOSm as far as I know.

comment:4 Changed 8 years ago by naoliv

I remember seeing something for the map font but didn't find anything related to configure the other fonts (that why I have opened this wishlist bug).

comment:5 Changed 8 years ago by Don-vip

Owner: changed from team to Don-vip
Status: newassigned

Changed 8 years ago by Don-vip

Attachment: 8334.patch added

comment:6 Changed 8 years ago by Don-vip

Here's an alpha patch allowing to change font. It works, but the preferences dialog is much slower to open because of the combobox lazy initialization. A faster mechanism has to be written, based on LanguagePreference experience.

comment:7 Changed 6 years ago by Don-vip

Owner: changed from Don-vip to team
Status: assignednew

comment:8 Changed 6 years ago by Don-vip

Keywords: font added

comment:9 Changed 3 years ago by Don-vip

Ticket #14745 has been marked as a duplicate of this ticket.

Changed 3 years ago by jidanni

Attachment: k.jpg added

Please do something. Users of Chinese must click Edit on each item just to see what it says!

comment:10 Changed 3 years ago by bastiK

jidanni: The text is very crude and unreadable on your system. As you can see in comparison to the first attached image, this is not normal and therefore does not affect all Chinese users. Please open a separate ticket and add a status report.

comment:11 Changed 3 years ago by naoliv

Most probably Jidanni needs -Dawt.useSystemAAFontSettings=on for anti-aliased text

comment:12 Changed 3 weeks ago by simon04

In 16960/josm:

see #8334 - Add advanced option to scale the table font

Advanced preference keys gui.scale.table.*

comment:13 Changed 3 weeks ago by simon04

In 16961/josm:

see #8334 - Add advanced option to scale the list font

Advanced preference key gui.scale.list.font

comment:14 Changed 3 weeks ago by simon04

Milestone: 20.08

comment:15 Changed 3 weeks ago by simon04

Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.