Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#8237 closed defect (fixed)

split area throws exception instead of "wrong selection info"

Reported by: skyper Owned by: team
Priority: normal Milestone:
Component: Plugin utilsplugin2 Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. select one closed way, one line to split along and one common node of both
  2. Press Alt+X

What is the expected result?

  • The split will work ignoring the extra selected node.
  • at least give an info about wrong selection.

What happens instead?

IndexOutOfBoundsException

Please provide any additional information below. Attach a screenshot if
possible.

I just had still selected one of the common nodes when trying to split.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-11-29 02:31:07
Last Changed Author: stoecker
Revision: 5608
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-11-28 23:47:46 +0100 (Wed, 28 Nov 2012)
Last Changed Rev: 5608

Identification: JOSM/1.5 (5608 de)
Memory Usage: 435 MB / 592 MB (192 MB allocated, but free)
Java version: 1.6.0_24, Sun Microsystems Inc., OpenJDK 64-Bit Server VM
Operating system: Linux
Dataset consistency test: No problems found

Plugin: PicLayer (28807)
Plugin: terracer (28807)
Plugin: utilsplugin2 (28807)

java.lang.IndexOutOfBoundsException: Index: 1, Size: 1
	at java.util.LinkedList.entry(LinkedList.java:382)
	at java.util.LinkedList.get(LinkedList.java:332)
	at org.openstreetmap.josm.plugins.utilsplugin2.actions.SplitObjectAction.actionPerformed(SplitObjectAction.java:183)
	at javax.swing.SwingUtilities.notifyAction(SwingUtilities.java:1660)
	at javax.swing.JComponent.processKeyBinding(JComponent.java:2852)
	at javax.swing.KeyboardManager.fireBinding(KeyboardManager.java:285)
	at javax.swing.KeyboardManager.fireKeyboardAction(KeyboardManager.java:247)
	at javax.swing.JComponent.processKeyBindingsForAllComponents(JComponent.java:2929)
	at javax.swing.JComponent.processKeyBindings(JComponent.java:2921)
	at javax.swing.JComponent.processKeyEvent(JComponent.java:2815)
	at java.awt.Component.processEvent(Component.java:6166)
	at java.awt.Container.processEvent(Container.java:2045)
	at java.awt.Component.dispatchEventImpl(Component.java:4750)
	at java.awt.Container.dispatchEventImpl(Container.java:2103)
	at java.awt.Component.dispatchEvent(Component.java:4576)
	at java.awt.KeyboardFocusManager.redispatchEvent(KeyboardFocusManager.java:1895)
	at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(DefaultKeyboardFocusManager.java:769)
	at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(DefaultKeyboardFocusManager.java:1045)
	at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(DefaultKeyboardFocusManager.java:912)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(DefaultKeyboardFocusManager.java:734)
	at java.awt.Component.dispatchEventImpl(Component.java:4620)
	at java.awt.Container.dispatchEventImpl(Container.java:2103)
	at java.awt.Window.dispatchEventImpl(Window.java:2518)
	at java.awt.Component.dispatchEvent(Component.java:4576)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:672)
	at java.awt.EventQueue.access$400(EventQueue.java:96)
	at java.awt.EventQueue$2.run(EventQueue.java:631)
	at java.awt.EventQueue$2.run(EventQueue.java:629)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:116)
	at java.awt.EventQueue$3.run(EventQueue.java:645)
	at java.awt.EventQueue$3.run(EventQueue.java:643)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:642)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)

Attachments (1)

bug_8237_example.osm (1.1 KB) - added by skyper 6 years ago.
sample

Download all attachments as: .zip

Change History (5)

comment:1 Changed 6 years ago by Don-vip

Cannot reproduce. Can you attach a .osm sample file ? thanks

comment:2 in reply to:  1 Changed 6 years ago by skyper

Replying to Don-vip:

Cannot reproduce. Can you attach a .osm sample file ? thanks

Here you go:

  • just select both ways and node A.
  • split (Alt+X).

Changed 6 years ago by skyper

Attachment: bug_8237_example.osm added

sample

comment:3 Changed 6 years ago by Don-vip

Resolution: fixed
Status: newclosed

Fixed in [o29121].

comment:4 Changed 6 years ago by anonymous

Ticket #8363 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.