Modify

Opened 7 years ago

Closed 7 years ago

#8216 closed defect (duplicate)

Error when resolving conflicts

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: template_report conflict Cc:

Description

What steps will reproduce the problem?

  1. I was resolving conflicts then error happens, i dont know what trigger is

What is the expected result?

Work fine

What happens instead?

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-11-10 02:31:13
Last Changed Author: bastiK
Revision: 5576
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-11-09 21:16:38 +0100 (Fri, 09 Nov 2012)
Last Changed Rev: 5576

Identification: JOSM/1.5 (5576 cs)
Memory Usage: 1065 MB / 3637 MB (197 MB allocated, but free)
Java version: 1.7.0_09, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Operating system: Windows 7

Dataset consistency test:
[DELETED REFERENCED] {Way id=192483189 version=0 MVT nodes=[{Node id=172583959 version=2 VD lat=34.738623,lon=-77.469542}, {Node id=2030367237 version=1 MV lat=34.73844238373046,lon=-77.46967558278163}, {Node id=2030367231 version=1 MV lat=34.738251417368836,lon=-77.46974909270808}, {Node id=2030367227 version=1 MV lat=34.738123653956315,lon=-77.46968036543697}, {Node id=2030367217 version=1 MV lat=34.73680551488077,lon=-77.46897131026054}, {Node id=2030367214 version=1 MV lat=34.736427471513444,lon=-77.46861324578012}, {Node id=2030367210 version=1 MV lat=34.73633393474329,lon=-77.46847096850313}, {Node id=2030367209 version=1 MV lat=34.7362566606641,lon=-77.46832879019593}]} refers to deleted primitive {Node id=172583959 version=2 VD lat=34.738623,lon=-77.469542}
[WARN - NO NODES] Way {Way id=174420566 version=1 V nodes=[{Node id=1851181055 version=1 V lat=33.8051792,lon=-117.9205328}]} has only one node


Plugin: DirectDownload (28807)
Plugin: DirectUpload (28807)
Plugin: ElevationProfile (28150)
Plugin: InfoMode (28807)
Plugin: OpeningHoursEditor (28656)
Plugin: PicLayer (28807)
Plugin: Tracer (28807)
Plugin: continuosDownload (28565)
Plugin: czechaddress (28807)
Plugin: dataimport (28656)
Plugin: download_along (28807)
Plugin: gpxfilter (28656)
Plugin: mapdust (28807)
Plugin: merge-overlap (28807)
Plugin: mirrored_download (28939)
Plugin: namemanager (28807)
Plugin: openstreetbugs (28807)
Plugin: restart (28492)
Plugin: reverter (28820)
Plugin: todo (28793)
Plugin: turnlanes (28807)
Plugin: utilsplugin2 (28807)
Plugin: wayselector (28807)
Plugin: wikipedia (28807)

org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Deleted node referenced: {Way id=192483189 version=0 MVT nodes=[{Node id=172583959 version=2 VD lat=34.738623,lon=-77.469542}, {Node id=2030367237 version=1 MV lat=34.73844238373046,lon=-77.46967558278163}, {Node id=2030367231 version=1 MV lat=34.738251417368836,lon=-77.46974909270808}, {Node id=2030367227 version=1 MV lat=34.738123653956315,lon=-77.46968036543697}, {Node id=2030367217 version=1 MV lat=34.73680551488077,lon=-77.46897131026054}, {Node id=2030367214 version=1 MV lat=34.736427471513444,lon=-77.46861324578012}, {Node id=2030367210 version=1 MV lat=34.73633393474329,lon=-77.46847096850313}, {Node id=2030367209 version=1 MV lat=34.7362566606641,lon=-77.46832879019593}]}
	at org.openstreetmap.josm.data.osm.Way.checkNodes(Way.java:580)
	at org.openstreetmap.josm.data.osm.Way.setDataset(Way.java:605)
	at org.openstreetmap.josm.data.osm.DataSet.addPrimitive(DataSet.java:371)
	at org.openstreetmap.josm.data.osm.OsmPrimitive.setOsmId(OsmPrimitive.java:368)
	at org.openstreetmap.josm.io.DiffResultProcessor.postProcess(DiffResultProcessor.java:126)
	at org.openstreetmap.josm.io.OsmApi.uploadDiff(OsmApi.java:513)
	at org.openstreetmap.josm.io.OsmServerWriter.uploadChangesInChunks(OsmServerWriter.java:172)
	at org.openstreetmap.josm.io.OsmServerWriter.uploadOsm(OsmServerWriter.java:214)
	at org.openstreetmap.josm.gui.io.UploadPrimitivesTask.realRun(UploadPrimitivesTask.java:247)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:82)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:145)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

Attachments (0)

Change History (1)

comment:1 Changed 7 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #6529.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.