Modify

Opened 7 years ago

Closed 6 years ago

#8156 closed defect (duplicate)

problem uploading undeleted way, precondition failed

Reported by: dieterdreist Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: undelete way precondition failed Cc:

Description (last modified by dieterdreist)

I undeleted a way but JOSM won't let me upload the result because the nodes are still deleted:
errormessage is this:

Uploading to the server failed because your current dataset violates a precondition. The error message is: ResponseCode=412, Error Header=<Precondition failed: Way 141612459 requires the nodes with id in (1550129334,1550129338,1550129347,1550129351,1550129352,1550129357,1550129365,1550129369,1550129370,1550129398,155012940

I tried to update the dataset, but the last modifier still remains the user who deleted the way even after slightly moving all of these nodes (I also deleted the automatically "history"-tag on the objects).

I don't understand why I don't get conflict resolution to pop up.

Attachments (0)

Change History (6)

comment:1 Changed 7 years ago by dieterdreist

Description: modified (diff)
Summary: problem with undeleted wayproblem uploading undeleted way, precondition failed

comment:2 Changed 7 years ago by dieterdreist

I could resolve this by saving locally and change the "visible"-attribute for the nodes in question from "true" to "false" before uploading. After uploading they were all visible. The nodes already had the "modify"-flag set (I guess because I had moved them slightly, I thought this would flag them "modify", but it didn't help for the precondition problem).

Last edited 7 years ago by dieterdreist (previous) (diff)

comment:3 Changed 7 years ago by mjulius

How did you undelete the way? Using the undelete plugin? I guess you need to undelete its nodes separately. Of course, it would be more comfortable if the plugin did that automatically.

comment:4 Changed 7 years ago by dieterdreist

Yes, I was using the undelete plugin. I think it should undelete the nodes as well (the nodes were visible in the JOSM viewport so I guess this is a bug if they hadn't been undeleted as well?) Maybe they get undeleted but the version number is not increased so the server rejects them on upload?

Last edited 7 years ago by dieterdreist (previous) (diff)

comment:5 Changed 7 years ago by skyper

See also #7986

comment:6 Changed 6 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #7116.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.