Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#8105 closed defect (fixed)

TypeError: not all arguments converted during string formatting

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description

Como Reproduzir

Enquanto executava a operação POST em /register, o Trac lançou um erro interno.

(por favor forneça detalhes adicionais aqui)

Parâmetros Requisitados:

{'__FORM_TOKEN': u'b5890af11d95fe996f72fd04',
 'action': u'create',
 'email': u'deborapazsales@gmail.com',
 'name': u'deborapazsales',
 'password': u'adeblaadebla',
 'password_confirm': u'adeblaadebla',
 'sentinel': u'',
 'sfp_email': u'',
 'sfph_mail': u'',
 'spf_url': u'',
 'username': u'deborapazsales'}

User agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.1 (KHTML, like Gecko) Chrome/21.0.1180.89 Safari/537.1

Informações do Sistema

Informações do sistema não disponíveis

Plugins Habilitados

Informações de Plugin não disponíveis

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/Trac-1.0-py2.7.egg/trac/web/main.py", line 497, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.7/dist-packages/Trac-1.0-py2.7.egg/trac/web/main.py", line 214, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/local/lib/python2.7/dist-packages/TracAccountManager-0.4dev_r12050-py2.7.egg/acct_mgr/register.py", line 362, in process_request
    acctmgr.validate_registration(req)
  File "/usr/local/lib/python2.7/dist-packages/TracAccountManager-0.4dev_r12050-py2.7.egg/acct_mgr/api.py", line 358, in validate_registration
    inspector.validate_registration(req)
  File "build/bdist.linux-x86_64/egg/tracspamfilter/accountadapter.py", line 54, in validate_registration
    FilterSystem(self.env).test(req, author, changes)
  File "build/bdist.linux-x86_64/egg/tracspamfilter/filtersystem.py", line 173, in test
    self.log.warn("Test returned %s" % (retval))
TypeError: not all arguments converted during string formatting

Attachments (0)

Change History (2)

comment:1 Changed 10 years ago by stoecker

Resolution: fixed
Status: newclosed

Temporary error caused by a typo in a debug statement. Sorry for that :-)

comment:2 Changed 10 years ago by stoecker

Ticket #8106 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.