Modify

Opened 8 years ago

Closed 8 days ago

#8082 closed defect (duplicate)

Splitting way breaks relations which are not downloaded

Reported by: Larry0ua Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: split Cc:

Description (last modified by Larry0ua)

Steps to reproduce the bug:

  1. Download relation 1742393.
  2. Select any node that is in the middle of the way.
  3. Press P to split way.

Observed behavior:
way is splitted, but relations that use this way become broken as they now include only old part of the way, not new. Also, as these relations are not loaded to JOSM this situation is unable to solve in the client side.

Desired behavior one of the following:

  • message box is shown saying "You are going to split way that is not downloaded completely. That may break relations using this way. Download way completely before splitting?" with buttons "Download" (green download icon), "Split without downloading" (no icon), "Cancel" (red cross icon - cancel default)
  • some epsilon bounds around the point is downloaded and then way is splitted (not really preferred way to solve the ticket as is not obvious to the user)

Attachments (0)

Change History (8)

comment:1 Changed 8 years ago by Larry0ua

Description: modified (diff)

comment:2 Changed 5 years ago by malenki

Maybe related to #10838?

comment:3 Changed 5 years ago by skyper

+1

default should be to request parent relations prior to split and deny splitting (if not in wiki:Help/ExpertMode).

comment:4 Changed 4 years ago by simon04

Summary: Way Splitter - breaks relations when way is incompleteSplitting way breaks relations which are not downloaded

comment:5 Changed 2 months ago by skyper

Resolution: duplicate
Status: newclosed

Closed as duplicate of #18596.
There is already work done in #18596.

comment:6 Changed 2 weeks ago by skyper

support for route, multipolygon and boundary has been added in #18596.
turn_restriction is covered in #10808.

If there are more unsupported types, please, open a new ticket.

comment:7 Changed 8 days ago by skyper

Resolution: duplicate
Status: closedreopened

comment:8 Changed 8 days ago by skyper

Resolution: duplicate
Status: reopenedclosed

Closed as duplicate of #17898.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.