Modify

Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#8080 closed defect (fixed)

ElevationProfile slows down Josm

Reported by: arnotixe@… Owned by: OliverW
Priority: normal Milestone:
Component: Plugin elevationprofile Version:
Keywords: slow perf performance Cc:

Description

On linux mint with current josm and elevationprofile, it slows down josm very much. Like 4-5 seconds between action till anything is visible.

Disabling the plugin makes josm run as fast as usual.

Attachments (1)

session.joz (84.4 KB) - added by akks 6 years ago.
elevation profile starnge jumps (offtopic, but newely introduced)

Download all attachments as: .zip

Change History (24)

comment:1 Changed 7 years ago by anonymous

Component: CorePlugin elevationprofile
Owner: changed from team to OliverW

hmm sorry that was elevationplugin, yes

comment:2 Changed 7 years ago by bastiK

I think we have to do something about this, some users might not be able to figure out that the plugin causes the slow down.

comment:3 Changed 7 years ago by OliverW

I understand this, but I'm currently busy with other tasks :-(

comment:4 Changed 7 years ago by Don-vip

Any idea where the problem is ? I will be glad to help.

comment:5 Changed 7 years ago by OliverW

I suspect that the Rendering of the Elevation Profile is the Root cause. It is not coded very well, so I would give it a try. Thanks in advance for your support.

comment:6 Changed 6 years ago by Manu1400

Keywords: perf performance added

comment:7 Changed 6 years ago by OliverW

Anything new? Currently I have some time to look after this - so any further hints (e. g. an attached GPX file) would be fine.

I tested it with many different files and I did not recognize any perf losses so far.

comment:8 Changed 6 years ago by Don-vip

I didn't have a look at this, sorry.

However, a comment on [o29869]. We have not yet switched to Java 7 (see #8465). Plugins must remain compatible with Java 6 until we switch.

I see you're supporting SRTM files now, that's cool. Is there a chance we can close #1729 with your plugin updates ? :)

comment:9 Changed 6 years ago by OliverW

I think that #1729 aims on is a 'little bit' beyond the scope of the ElevationPlugin. However, I could add another layer...

comment:10 Changed 6 years ago by anonymous

I can confirm this issue on Win7 64 bit with Java 7. Once the window "elevation profile" is being made visible the cpu usage of javaw.exe increases from 0 % to constantly 22-23 % at idle. This happens regardless whether a gpx file is loaded/active/was loaded at all or not. I don't see a performance drop but that might depend upon the machine used and how much resources are available. But I do hear the increasing noisy fan sound caused by the increased cpu load and the heating as a consequence thereof.

When you close the window "elevation profile" the cpu load drops to 0 % at idle.

comment:11 Changed 6 years ago by OliverW

Indeed the plugin slows down JOSM due to unnecessary repaints. I'm currently redesign the plugin and will take this into account.

comment:12 Changed 6 years ago by OliverW

Resolution: fixed
Status: newclosed

Provided fix via [o29951], please check if cpu load is still high

Last edited 6 years ago by stoecker (previous) (diff)

comment:13 Changed 6 years ago by akks

I am afraid it is still slow (when layer is visible)
there are also multiple messages

readElevation: Buffer is null for tag 'N54E056.hgt'

in the console. Tried recompilation (ant clean, ant dist, ant install) - no changes.

Last edited 6 years ago by akks (previous) (diff)

comment:14 Changed 6 years ago by OliverW

Sorry, try 29953

comment:15 Changed 6 years ago by Don-vip

@OliverW: we have not yet switched to Java 7, see #8465 for migration plan. In the meanwhile, all plugins must remain compatible with Java 6.

comment:16 Changed 6 years ago by anonymous

The cpu usage problem is gone in 29953 (Win7 64 bit with Java 7).

comment:17 Changed 6 years ago by akks

Thank you! I confirm, the CPU load problem is gone.

I noticed some artefact (or feature) was introduced with the last commit (for strange airplane trackpoints) - see the attached session file.

Changed 6 years ago by akks

Attachment: session.joz added

elevation profile starnge jumps (offtopic, but newely introduced)

comment:18 Changed 6 years ago by OliverW

Thanks for the data, but how do I open/view this file? I read that it is a zipped .jos file but 7-zip does not recognize the file as ZIP archive. Also (my) JOSM cannot load it. Is there a plugin needed or how can I proceed?

comment:19 in reply to:  18 Changed 6 years ago by AlfonZ

Replying to OliverW:

Thanks for the data, but how do I open/view this file? I read that it is a zipped .jos file but 7-zip does not recognize the file as ZIP archive. Also (my) JOSM cannot load it. Is there a plugin needed or how can I proceed?

JOSM 6245 (or later) can open it directly via File/Open,
JOSM 6129 (or later) can open it via File/Session/Load Session.
With older JOSM you can try setting advanced property session to true, menu item File/Session should appear.

comment:20 in reply to:  15 ; Changed 6 years ago by OliverW

Replying to Don-vip:

@OliverW: we have not yet switched to Java 7, see #8465 for migration plan. In the meanwhile, all plugins must remain compatible with Java 6.

Now I'm really confused
# Downloaded JOSM 6238 and it says "You should update to Java 7 asap"
==> Did I miss something?

Regarding your session: I recognized that in some cases, too. Should be fixed with r29977

Last edited 6 years ago by OliverW (previous) (diff)

comment:21 in reply to:  20 Changed 6 years ago by AlfonZ

Replying to OliverW:

# Downloaded JOSM 6238 and it says "You should update to Java 7 asap"

Would you please add information about your system?

comment:22 Changed 6 years ago by OliverW

Sure:

Java(TM) SE Runtime Environment (build 1.7.0-b147)
Java HotSpot(TM) 64-Bit Server VM (build 21.0-b17, mixed mode)

Plugins compiled with 1.6 compliance

comment:23 Changed 6 years ago by Don-vip

We are in the process of switching to Java 7 but it takes a while. That's why we ask end users to upgrade to this version. But as a plugin author you must ensure it runs well with java 6 too as we still have a large base of users running java 6 (still 25%)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain OliverW.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.