Modify

Opened 7 years ago

Closed 6 years ago

#8066 closed enhancement (duplicate)

Add funktion to remove node from way

Reported by: jochen@… Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description

A very common situation is this: There are two ways using the same node, for instance a highway and a powerline. But they are not supposed to use the same node. In fact one of the lines should not use the node at all. I can use the unglue function and then remove one of the nodes, but thats cumbersome. And it has the problem that in half the cases the way that could be left untouched has now a spurious change.

So I suggest a new function to remove a node from a way. To use it you select the node and the way and then the menu function/key.

Attachments (0)

Change History (3)

comment:1 in reply to:  description Changed 7 years ago by skyper

Replying to jochen@…:

A very common situation is this: There are two ways using the same node, for instance a highway and a powerline. But they are not supposed to use the same node. In fact one of the lines should not use the node at all. I can use the unglue function and then remove one of the nodes, but thats cumbersome.

Is it to hard to select the two objects (node plus way of which you want to delete the node of) press "g" and "Del" and that is it.

And it has the problem that in half the cases the way that could be left untouched has now a spurious change.

No, you only need to select the right objects.

Last edited 7 years ago by skyper (previous) (diff)

comment:2 Changed 7 years ago by Don-vip

Have you tried the "Extract node (Alt-J)" function from utilsplugin2 ?

comment:3 Changed 6 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #5133.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.