Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#8059 closed defect (fixed)

defaultpreset.xml error when choosing Turkish as language in JOSM

Reported by: katpatuka Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: turkish language presets Cc: katpatuka

Description

Can someone else please confirm the following error when the language is set to Turkish:

java.lang.reflect.InvocationTargetException

at sun.reflect.GeneratedMethodAccessor6.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.openstreetmap.josm.tools.XmlObjectParser$Parser.setValue(XmlObjectParser.java:197)
at org.openstreetmap.josm.tools.XmlObjectParser$Parser.startElement(XmlObjectParser.java:136)
at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.startElement(Unknown Source)
at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.scanStartElement(Unknown Source)
at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(Unknown Source)
at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(Unknown Source)
at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(Unknown Source)
at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)
at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(Unknown Source)
at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(Unknown Source)
at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Source)
at org.openstreetmap.josm.tools.XmlObjectParser.start(XmlObjectParser.java:293)
at org.openstreetmap.josm.tools.XmlObjectParser.start(XmlObjectParser.java:304)
at org.openstreetmap.josm.gui.tagging.TaggingPreset.readAll(TaggingPreset.java:1361)
at org.openstreetmap.josm.gui.tagging.TaggingPreset.readAll(TaggingPreset.java:1430)
at org.openstreetmap.josm.gui.tagging.TaggingPreset.readAll(TaggingPreset.java:1444)
at org.openstreetmap.josm.gui.tagging.TaggingPreset.readFromPreferences(TaggingPreset.java:1479)
at org.openstreetmap.josm.gui.preferences.map.TaggingPresetPreference.initialize(TaggingPresetPreference.java:271)
at org.openstreetmap.josm.Main$2.call(Main.java:337)
at org.openstreetmap.josm.Main$2.call(Main.java:330)
at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
at java.util.concurrent.FutureTask.run(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

Caused by: org.xml.sax.SAXException: Unknown type: relation

at org.openstreetmap.josm.gui.tagging.TaggingPreset.getType(TaggingPreset.java:1303)
at org.openstreetmap.josm.gui.tagging.TaggingPreset.setType(TaggingPreset.java:1314)
... 30 more

org.openstreetmap.josm.tools.XmlObjectParser$PresetParsingException (at line 466, column 93)
resource://data/defaultpresets.xml
org.openstreetmap.josm.tools.XmlObjectParser$PresetParsingException: org.openstreetmap.josm.tools.XmlObjectParser$Preset
ParsingException (at line 466, column 93)
java.lang.reflect.InvocationTargetException

at org.openstreetmap.josm.tools.XmlObjectParser$Parser.throwException(XmlObjectParser.java:124)
at org.openstreetmap.josm.tools.XmlObjectParser$Parser.setValue(XmlObjectParser.java:202)
at org.openstreetmap.josm.tools.XmlObjectParser$Parser.startElement(XmlObjectParser.java:136)
at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.startElement(Unknown Source)
at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.scanStartElement(Unknown Source)
at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(Unknown Source)
at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(Unknown Source)
at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(Unknown Source)
at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)
at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(Unknown Source)
at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(Unknown Source)
at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Source)
at org.openstreetmap.josm.tools.XmlObjectParser.start(XmlObjectParser.java:293)
at org.openstreetmap.josm.tools.XmlObjectParser.start(XmlObjectParser.java:304)
at org.openstreetmap.josm.gui.tagging.TaggingPreset.readAll(TaggingPreset.java:1361)
at org.openstreetmap.josm.gui.tagging.TaggingPreset.readAll(TaggingPreset.java:1430)
at org.openstreetmap.josm.gui.tagging.TaggingPreset.readAll(TaggingPreset.java:1444)
at org.openstreetmap.josm.gui.tagging.TaggingPreset.readFromPreferences(TaggingPreset.java:1479)
at org.openstreetmap.josm.gui.preferences.map.TaggingPresetPreference.initialize(TaggingPresetPreference.java:271)
at org.openstreetmap.josm.Main$2.call(Main.java:337)
at org.openstreetmap.josm.Main$2.call(Main.java:330)
at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
at java.util.concurrent.FutureTask.run(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

Caused by: java.lang.reflect.InvocationTargetException

at sun.reflect.GeneratedMethodAccessor6.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.openstreetmap.josm.tools.XmlObjectParser$Parser.setValue(XmlObjectParser.java:197)
... 26 more

Caused by: org.xml.sax.SAXException: Unknown type: relation

at org.openstreetmap.josm.gui.tagging.TaggingPreset.getType(TaggingPreset.java:1303)
at org.openstreetmap.josm.gui.tagging.TaggingPreset.setType(TaggingPreset.java:1314)
... 30 more

platform is XP

I don't hope it's a problem of some class method containing capital "I" that may cause problems with Turkish locale - in Turkish there are 2 different vowels: iİ and ıI ...

This once used to be a problem in gallery2 which was then solved by something like:

setlocale(LC_CTYPE, 'C');

Attachments (1)

Adsız.png (53.6 KB) - added by katpatuka 10 years ago.
error screenshot

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by katpatuka

Attachment: Adsız.png added

error screenshot

comment:1 Changed 10 years ago by stoecker

In 5509/josm:

see #8059 - fix preset loading for tr

comment:2 Changed 10 years ago by stoecker

Resolution: fixed
Status: newclosed

In 5510/josm:

fix #8059 - fix preset loading for tr

comment:3 Changed 10 years ago by stoecker

Please reopen when there are other program functions, which don't work as expected in Turkish.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.