Modify

Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#796 closed defect (wontfix)

Empty dialog in Ubuntu: Modal Window "Upload These Changes" not usable after "Data with errors, upload anyway"

Reported by: oscar@… Owned by: framm
Priority: major Milestone:
Component: Core Version: latest
Keywords: Cc: JohannesRudolph

Description

Sometimes (quite often for me) the upload of changes I have done is not possible because the "Upload these changes" dialog has neither text or buttons.

Steps to get this error:

  • do some changes in JOSM (with "errors" like unnamed ways)
  • upload the changes
  • dialog "Data with errors, upload anyway" -> confirm
  • empty "Upload these Changes" Dialog appears.

To upload my changes anyway, I try to zoom in, zoom out, move in the editor window. After some of these actions I am able to upload again.

Attachments (2)

screen1.jpg (12.3 KB) - added by oscar@… 11 years ago.
Data With Errors dialog
screen2.jpg (7.2 KB) - added by oscar@… 11 years ago.
empty "Upload Changes" Dialog

Download all attachments as: .zip

Change History (9)

Changed 11 years ago by oscar@…

Attachment: screen1.jpg added

Data With Errors dialog

Changed 11 years ago by oscar@…

Attachment: screen2.jpg added

empty "Upload Changes" Dialog

comment:1 Changed 11 years ago by anonymous

What JOSM version do you use? What version of the validator plugin? What OS?

comment:2 in reply to:  1 Changed 11 years ago by oscar@…

Replying to anonymous:

What JOSM version do you use? What version of the validator plugin? What OS?

The problem appears with JOSM 757 and validator plugin 8911. The environment includes Sun's Java 1.5 and Ubuntu Linux.

comment:3 Changed 11 years ago by anonymous

Can you update Java? I fear that is a Java bug and no JOSM bug. Not reproducable here.

comment:4 Changed 11 years ago by JohannesRudolph

Cc: JohannesRudolph added

I've seen this bug, too. Not in JOSM AFAIR but in soapUI. It looks like the bug filed here:
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6632124

Can you confirm the setup, oscar? Ubuntu with Compiz desktop effects enabled?

comment:5 Changed 11 years ago by JohannesRudolph

Summary: Modal Window "Upload These Changes" not usable after "Data with errors, upload anyway"Empty dialog in Ubuntu: Modal Window "Upload These Changes" not usable after "Data with errors, upload anyway"

comment:6 Changed 11 years ago by JohannesRudolph

I made a quick test with various JDKs. The problem exists in the currently bundled OpenJdk and Sun Jdk versions from Ubuntu 8.4. There is a new Sun JDK version in the Ubuntu "Proposed Updates" which does not solve the problem.

I then checked the newest RC of the upcoming Sun JDK 6u10. It looks like this version finally fixed the error (as reported in the sun bug report 6632124). So you will probably have to wait until Sun finished the release and Ubuntu packages this one or you get the latest RC and use it.

comment:7 Changed 10 years ago by anonymous

Resolution: wontfix
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.