Modify

Opened 9 years ago

Closed 9 years ago

#7933 closed defect (duplicate)

Crash when downloading OSM data for Cairo Egypt

Reported by: brendonl@… Owned by: team
Priority: major Milestone:
Component: Core Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. start JOSM - no layers opened
  2. File/Download OSM
  3. select a small portion of Cairo
  4. after completes downloading it crashes when trying to display the layer

What is the expected result? Display the new data layer

What happens instead? crashes. Repeatable on two machines. Might be a language problem? Other cities OK.

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-07-23 01:31:06
Last Changed Author: Don-vip
Revision: 5356
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-07-22 22:36:44 +0200 (Sun, 22 Jul 2012)
Last Changed Rev: 5356

Identification: JOSM/1.5 (5356 en_AU)
Memory Usage: 129 MB / 494 MB (71 MB allocated, but free)
Java version: 1.6.0_31, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows 7
Dataset consistency test: No problems found

Plugin: PicLayer (27883)
Plugin: buildings_tools (27984)
Plugin: openstreetbugs (28412)
Plugin: terracer (27852)
Plugin: turnrestrictions (28412)
Plugin: walkingpapers (27649)

java.lang.NullPointerException
	at org.openstreetmap.josm.data.osm.visitor.paint.MapPainter.drawTextOnPath(MapPainter.java:464)
	at org.openstreetmap.josm.gui.mappaint.LineTextElemStyle.paintPrimitive(LineTextElemStyle.java:35)
	at org.openstreetmap.josm.data.osm.visitor.paint.StyledMapRenderer$StyleCollector.drawAll(StyledMapRenderer.java:139)
	at org.openstreetmap.josm.data.osm.visitor.paint.StyledMapRenderer.render(StyledMapRenderer.java:232)
	at org.openstreetmap.josm.gui.layer.OsmDataLayer.paint(OsmDataLayer.java:281)
	at org.openstreetmap.josm.gui.MapView.paintLayer(MapView.java:455)
	at org.openstreetmap.josm.gui.MapView.paint(MapView.java:534)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.pa

Attachments (0)

Change History (1)

comment:1 Changed 9 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #7907.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.