Modify

Opened 7 years ago

Closed 4 years ago

#7902 closed defect (fixed)

Exception loading geotiff

Reported by: mh@… Owned by: team
Priority: minor Milestone:
Component: Plugin importimage Version: tested
Keywords: geotiff import Cc:

Description

What steps will reproduce the problem?

  1. Load geotiff e.g. SRTM_f03_n053e008.tif

What is the expected result?
Display as underlay image or message that this format is not supported.

What happens instead?
Exception of the ImportImagePlugin.

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-07-23 01:31:06
Last Changed Author: Don-vip
Revision: 5356
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-07-22 22:36:44 +0200 (Sun, 22 Jul 2012)
Last Changed Rev: 5356

Identification: JOSM/1.5 (5356 de)
Memory Usage: 152 MB / 455 MB (32 MB allocated, but free)
Java version: 1.6.0_24, Sun Microsystems Inc., OpenJDK Server VM
Operating system: Linux

Plugin: ImportImagePlugin (28412)
Plugin: PicLayer (27883)
Plugin: RoadSigns (27868)
Plugin: contourmerge (1003)
Plugin: dataimport (28412)
Plugin: editgpx (27679)
Plugin: imageryadjust (28412)
Plugin: measurement (27679)
Plugin: merge-overlap (28412)
Plugin: multipoly-convert (28412)
Plugin: native_password_manager (27865)
Plugin: openstreetbugs (28412)
Plugin: osmarender (28412)
Plugin: reltoolbox (28412)
Plugin: turnlanes (28412)
Plugin: turnrestrictions (28412)
Plugin: utilsplugin2 (28412)

java.lang.ArrayIndexOutOfBoundsException: -1
	at java.awt.image.ComponentColorModel.getRGBComponent(ComponentColorModel.java:903)
	at java.awt.image.ComponentColorModel.getRed(ComponentColorModel.java:944)
	at java.awt.image.ComponentColorModel.getRGB(ComponentColorModel.java:1135)
	at sun.java2d.loops.OpaqueCopyAnyToArgb.Blit(CustomComponent.java:145)
	at sun.java2d.loops.GraphicsPrimitive.convertFrom(GraphicsPrimitive.java:558)
	at sun.java2d.loops.GraphicsPrimitive.convertFrom(GraphicsPrimitive.java:539)
	at sun.java2d.loops.MaskBlit$General.MaskBlit(MaskBlit.java:189)
	at sun.java2d.loops.Blit$GeneralMaskBlit.Blit(Blit.java:204)
	at sun.java2d.pipe.DrawImage.blitSurfaceData(DrawImage.java:956)
	at sun.java2d.pipe.DrawImage.renderImageCopy(DrawImage.java:578)
	at sun.java2d.pipe.DrawImage.copyImage(DrawImage.java:71)
	at sun.java2d.pipe.DrawImage.copyImage(DrawImage.java:1011)
	at sun.java2d.pipe.ValidatePipe.copyImage(ValidatePipe.java:186)
	at sun.java2d.SunGraphics2D.drawImage(SunGraphics2D.java:3071)
	at sun.java2d.SunGraphics2D.drawImage(SunGraphics2D.java:3056)
	at sun.java2d.pipe.DrawImage.makeBufferedImage(DrawImage.java:334)
	at sun.java2d.pipe.DrawImage.renderImageXform(DrawImage.java:394)
	at sun.java2d.pipe.DrawImage.transformImage(DrawImage.java:268)
	at sun.java2d.pipe.DrawImage.copyImage(DrawImage.java:80)
	at sun.java2d.pipe.DrawImage.copyImage(DrawImage.java:1011)
	at sun.java2d.pipe.ValidatePipe.copyImage(ValidatePipe.java:186)
	at sun.java2d.SunGraphics2D.drawImage(SunGraphics2D.java:3071)
	at sun.java2d.SunGraphics2D.drawImage(SunGraphics2D.java:3056)
	at org.openstreetmap.josm.plugins.ImportImagePlugin.ImageLayer.paint(ImageLayer.java:210)
	at org.openstreetmap.josm.gui.MapView.paintLayer(MapView.java:455)
	at org.openstreetmap.josm.gui.MapView.paint(MapView.java:534)
	at javax.swing.JComponent.paintChildren(JComponent.java:866)
	at javax.swing.JComponent.paint(JComponent.java:1038)
	at javax.swing.JComponent.paintToOffscreen(JComponent.java:5138)
	at javax.swing.BufferStrategyPaintManager.paint(BufferStrategyPaintManager.java:302)
	at javax.swing.RepaintManager.paint(RepaintManager.java:1188)
	at javax.swing.JComponent._paintImmediately(JComponent.java:5086)
	at javax.swing.JComponent.paintImmediately(JComponent.java:4896)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:783)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:735)
	at javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:677)
	at javax.swing.RepaintManager.access$700(RepaintManager.java:58)
	at javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1593)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:226)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:647)
	at java.awt.EventQueue.access$000(EventQueue.java:96)
	at java.awt.EventQueue$1.run(EventQueue.java:608)
	at java.awt.EventQueue$1.run(EventQueue.java:606)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:617)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:194)
	at java.awt.Dialog$1.run(Dialog.java:1072)
	at java.awt.Dialog$3.run(Dialog.java:1126)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.Dialog.show(Dialog.java:1124)
	at java.awt.Component.show(Component.java:1551)
	at java.awt.Component.setVisible(Component.java:1503)
	at java.awt.Window.setVisible(Window.java:881)
	at java.awt.Dialog.setVisible(Dialog.java:1011)
	at org.openstreetmap.josm.gui.HelpAwareOptionPane.showOptionDialog(HelpAwareOptionPane.java:236)
	at org.openstreetmap.josm.plugins.PluginHandler.confirmDeactivatingPluginAfterException(PluginHandler.java:949)
	at org.openstreetmap.josm.plugins.PluginHandler.disablePluginAfterException(PluginHandler.java:1014)
	at org.openstreetmap.josm.tools.BugReportExceptionHandler$1.run(BugReportExceptionHandler.java:76)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:226)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:647)
	at java.awt.EventQueue.access$000(EventQueue.java:96)
	at java.awt.EventQueue$1.run(EventQueue.java:608)
	at java.awt.EventQueue$1.run(EventQueue.java:606)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:617)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
...<snip>...

Attachments (1)

SRTM_f03_n053e008.tif.bz2 (262.1 KB) - added by mh@… 7 years ago.
bzip2 compressed (due to 2.0MB limit) geotiff file to reproduce the ImportImage exception.

Download all attachments as: .zip

Change History (2)

Changed 7 years ago by mh@…

Attachment: SRTM_f03_n053e008.tif.bz2 added

bzip2 compressed (due to 2.0MB limit) geotiff file to reproduce the ImportImage exception.

comment:1 Changed 4 years ago by Don-vip

Resolution: fixed
Status: newclosed

Cannot reproduce. Might have been fixed in the course of #12097, or maybe it was an old bug of Java 6.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.