Modify

Opened 7 years ago

Closed 5 years ago

#7883 closed defect (fixed)

IndexOutOfBoundsException when aligning segment with free node using Angle preservation

Reported by: AlfonZ Owned by: tilusnet
Priority: normal Milestone:
Component: Plugin alignways Version:
Keywords: Cc: OSM@…, OsmAR

Description


Build-Date: 2012-07-20 00:56:06
Revision: 5353
Is-Local-Build: true

Identification: JOSM/1.5 (5353 SVN en)
Memory Usage: 123 MB / 1484 MB (78 MB allocated, but free)
Java version: 1.7.0_05, Oracle Corporation, Java HotSpot(TM) Client VM
Operating system: Windows XP
Dataset consistency test: No problems found

Plugin: alignways (28412)

java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
	at java.util.ArrayList.rangeCheck(Unknown Source)
	at java.util.ArrayList.get(Unknown Source)
	at com.tilusnet.josm.plugins.alignways.AlignWaysCmdKeepAngles.recalculateNodesAndValidate(AlignWaysCmdKeepAngles.java:68)
	at com.tilusnet.josm.plugins.alignways.AlignWaysCmdKeepAngles.<init>(AlignWaysCmdKeepAngles.java:49)
	at com.tilusnet.josm.plugins.alignways.AlignWaysAction.actionPerformed(AlignWaysAction.java:61)
	at javax.swing.SwingUtilities.notifyAction(Unknown Source)
...

Attachments (2)

AngleAlign_OneFreeEnd.osm (934 bytes) - added by AlfonZ 7 years ago.
AngleAlign_OneFreeEnd.png (11.2 KB) - added by AlfonZ 7 years ago.

Download all attachments as: .zip

Change History (8)

Changed 7 years ago by AlfonZ

Attachment: AngleAlign_OneFreeEnd.osm added

Changed 7 years ago by AlfonZ

Attachment: AngleAlign_OneFreeEnd.png added

comment:1 Changed 7 years ago by AlfonZ

Ticket #7955 has been marked as a duplicate of this ticket.

comment:2 Changed 7 years ago by tilusnet

It looks like the problem appears with uncommitted way segments. I will have a look at this soon. For the time being please commit your new segments and apply the aligning afterwards. Let me know if you encounter problems with this workaround.

comment:3 Changed 6 years ago by Don-vip

Ticket #8718 has been marked as a duplicate of this ticket.

comment:4 Changed 6 years ago by Don-vip

Cc: OSM@… OsmAR added

comment:5 Changed 6 years ago by Don-vip

@tilusnet: any update on this ?

comment:6 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

Fixed in [o30631:30632].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain tilusnet.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.