Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#7875 closed defect (duplicate)

Can only download very small map data

Reported by: midibase@… Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description

Hello, I use Version 5315

with Windows 7, 64Bit, Java 7.0.50.5

It's not possible to get a bigger size of map data (say bigger than a house)from the OSM-Server. It's hanging always up, so its neccessary to switch to the taskmanager and kill the Java process.
Til the flat of app. one house it's working. On the dialogwindow "Downloading data" the statustext show Downloading OSM data .. 21 KB (sometimes 47 KB) and freezing. It does not react to the Cancel button :)
Please give me an hint what could be the problem?
Thanks midibase

Attachments (1)

Unbenannt.PNG (18.1 KB) - added by midibase@… 6 years ago.
freezing dialog while downloading map data from the osm server

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by midibase@…

Attachment: Unbenannt.PNG added

freezing dialog while downloading map data from the osm server

comment:1 Changed 6 years ago by stoecker

The issue with the Cancel button is known but yet unfixed. The freezing probably is caused by breaking of the download network connection. Maybe you have a broken proxy inbetween?

comment:2 Changed 6 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #7813.

comment:3 in reply to:  1 Changed 6 years ago by anonymous

Replying to stoecker:

The issue with the Cancel button is known but yet unfixed. The freezing probably is caused by breaking of the download network connection. Maybe you have a broken proxy inbetween?

No there are no proxy between :( It depends also not on the map area. I tried it also a seperate Laptop (Win7/64Bit) with the same disappointment. Possible a JAVA itself or a 64 Bit problem?!? I don't think that it could be a network problem because each others work very well. And I have so much bike-Information for the OSM and can't do anything. I am sad :(

comment:4 Changed 6 years ago by stoecker

It would be important to find the root cause of the issue:

  • Java - does Java6 work?
  • The OSM-server. When you call josm from commandline, you should see the requests send to the server. When you send such a request in the web-browser do you get full data (must start end end with same tag)?
  • Maybe it is a simple delay and you need only to wait much longer?
  • Currently the API is under a lot of stress due to the data redaction. Maybe that results in longer wait times. Try setting the variables socket.timeout.connect or socket.timeout.read to higher/lower values (you find them in expter mode under the last settings picture.

In any case, please report results.

Last edited 6 years ago by stoecker (previous) (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.