Modify

Opened 7 years ago

Closed 7 years ago

#7856 closed defect (fixed)

Wikipedia plugin (v. 28486 ) crashes while getting the list of articles of a Wikipedia category

Reported by: coso Owned by: simon04
Priority: normal Milestone:
Component: Plugin wikipedia Version: tested
Keywords: template_report Cc:

Description

  1. Download some data from the city of Venice (Italy)
  2. Set "it" as language in the plugin preferences
  3. click on "Category" button, write "Venezia", click OK
  4. the plugin crashes after a while
  5. the list of articles remains empty

The plugin works perfectly if a try with the name of a less important/smaller town, so maybe it is a problem of category dimension (just guessing).

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-07-03 01:31:22
Last Changed Author: simon04
Revision: 5315
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-07-02 14:51:19 +0200 (Mon, 02 Jul 2012)
Last Changed Rev: 5315

Identification: JOSM/1.5 (5315 it)
Memory Usage: 176 MB / 878 MB (76 MB allocated, but free)
Java version: 1.6.0_24, Sun Microsystems Inc., OpenJDK 64-Bit Server VM
Operating system: Linux
Dataset consistency test: No problems found

Plugin: wikipedia (28486)

java.lang.RuntimeException: java.io.IOException: Error writing to server
	at org.wikipedia.WikipediaApp.updateWIWOSMStatus(WikipediaApp.java:114)
	at org.wikipedia.WikipediaToggleDialog.setWikipediaEntries(WikipediaToggleDialog.java:101)
	at org.wikipedia.WikipediaToggleDialog.access$000(WikipediaToggleDialog.java:41)
	at org.wikipedia.WikipediaToggleDialog$WikipediaLoadCategoryAction.actionPerformed(WikipediaToggleDialog.java:148)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2012)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2335)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:404)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:252)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.Component.processMouseEvent(Component.java:6268)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3267)
	at java.awt.Component.processEvent(Component.java:6033)
	at java.awt.Container.processEvent(Container.java:2045)
	at java.awt.Component.dispatchEventImpl(Component.java:4629)
	at java.awt.Container.dispatchEventImpl(Container.java:2103)
	at java.awt.Component.dispatchEvent(Component.java:4455)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4633)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4297)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4227)
	at java.awt.Container.dispatchEventImpl(Container.java:2089)
	at java.awt.Window.dispatchEventImpl(Window.java:2517)
	at java.awt.Component.dispatchEvent(Component.java:4455)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:649)
	at java.awt.EventQueue.access$000(EventQueue.java:96)
	at java.awt.EventQueue$1.run(EventQueue.java:608)
	at java.awt.EventQueue$1.run(EventQueue.java:606)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:116)
	at java.awt.EventQueue$2.run(EventQueue.java:622)
	at java.awt.EventQueue$2.run(EventQueue.java:620)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:619)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)
Caused by: java.io.IOException: Error writing to server
	at sun.net.www.protocol.http.HttpURLConnection.writeRequests(HttpURLConnection.java:577)
	at sun.net.www.protocol.http.HttpURLConnection.writeRequests(HttpURLConnection.java:589)
	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1160)
	at java.net.URL.openStream(URL.java:1029)
	at org.wikipedia.WikipediaApp.updateWIWOSMStatus(WikipediaApp.java:102)
	... 40 more

Attachments (0)

Change History (1)

comment:1 Changed 7 years ago by simon04

Resolution: fixed
Status: newclosed

[o28488], [o28489].

Might take a while to status check 3000 articles of the category Venezia … ;-)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain simon04.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.