Modify

Opened 8 years ago

Closed 7 years ago

#7848 closed defect (fixed)

ConcurrentModificationException in DownloadPrimitivesTask

Reported by: simon04 Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc: naoliv

Description

Error occurred after the following:

  1. Download large area of railway=rail using mirrored_download plugin
  2. Download way 47296743 using download object

Not sure how to reproduce this easily …

Please provide any additional information below. Attach a screenshot if
possible.

Build-Date: 2012-07-12 10:41:22
Revision: 5326
Is-Local-Build: true

Identification: JOSM/1.5 (5326 SVN en)
Memory Usage: 217 MB / 3504 MB (89 MB allocated, but free)
Java version: 1.7.0_05-icedtea, Oracle Corporation, OpenJDK 64-Bit Server VM
Operating system: Linux
Dataset consistency test: No problems found

Plugin: HouseNumberTaggingTool (28412)
Plugin: SimplifyArea (27905)
Plugin: mirrored_download (28418)
Plugin: reltoolbox (28412)
Plugin: restart (28438)
Plugin: todo (28330)
Plugin: utilsplugin2 (28412)
Plugin: wikipedia (28472)

java.util.ConcurrentModificationException
	at java.util.ArrayList$Itr.checkForComodification(ArrayList.java:819)
	at java.util.ArrayList$Itr.next(ArrayList.java:791)
	at org.openstreetmap.josm.gui.io.DownloadPrimitivesTask.initMultiFetchReader(DownloadPrimitivesTask.java:107)
	at org.openstreetmap.josm.gui.io.DownloadPrimitivesTask.realRun(DownloadPrimitivesTask.java:136)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:82)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:145)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
	at java.lang.Thread.run(Thread.java:722)

Attachments (0)

Change History (3)

comment:1 Changed 7 years ago by Don-vip

Ticket #8502 has been marked as a duplicate of this ticket.

comment:2 Changed 7 years ago by Don-vip

Cc: naoliv added
Keywords: template_report removed

comment:3 Changed 7 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 5778/josm:

fix #7848 - ConcurrentModificationException in DownloadPrimitivesTask

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.