Modify

Opened 9 years ago

Closed 9 years ago

#7742 closed defect (duplicate)

Validator "way node end near other way" false reports

Reported by: AM909 Owned by: team
Priority: normal Milestone:
Component: Core validator Version: tested
Keywords: validator way end near Cc: AM909

Description (last modified by AM909)

In r5181:

The validator reports "way node end near other way" when it shouldn't - specifically for objects of different types. Examples:

  • A road (highway=*) that ends near an admin boundary (boundary=administrative + place=city + ...)
  • A road (highway=*) that ends near a river (waterway=river).
  • A road (highway=*) that ends near a power line (power=line). This probably doesn't happen if the power line has layer > that of the road, but few people seem to do this, and the validator doesn't report power lines crossing roads of the same layer, so it is apparently assumed that power lines are layer=6.
  • A fence (barrier=fence) that ends near a road (highway=*).

Basically, it seems this check is designed to find ways that should intersect, but don't. It should, therefore, limit itself to types of ways that should actually intersect (like those with the same main key, though there may be some others).

Attachments (0)

Change History (3)

comment:1 Changed 9 years ago by AM909

Description: modified (diff)

comment:2 Changed 9 years ago by mdk

This is an old problem (see #3531), but it is good if somebody bring it up again. The old ticket has lots of exapmples attached.

comment:3 Changed 9 years ago by skyper

Resolution: duplicate
Status: newclosed

Closed as duplicate of #3531.
Please comment and add examples to #3531.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.