Modify

Opened 10 years ago

Closed 9 years ago

#773 closed defect (fixed)

JOSM doesn't recognise a 412 precondition failed when a relation is uploaded.

Reported by: shaunmcdonald131@… Owned by: framm
Priority: blocker Milestone:
Component: Core Version: latest
Keywords: relations Cc: Gubaer

Description

If the server returns a 412 for a relation, JOSM just accepts it, and thinks it's ok. It doesn't tell the user that there is a problem like when the server returns a 500.

Attachments (0)

Change History (6)

comment:1 Changed 10 years ago by allgemein@…

I experienced the same.

You can reproduce it with the following steps:

The error was reproducible with the following variations:

  • download the incomplete relations 22956 and 7887 before adding the first one to the second
  • add node 21993086 (instead of relation 22956) to relation 7887

Adding relations or nodes to other relations (besides 7887) works properly here. Maybe there is something wrong with relation 7887?

An error message after the upload would surely be helpful to avoid user madness :)

Thanks for your work!

comment:2 Changed 10 years ago by anonymous

Resolution: fixed
Status: newclosed

Should be fixed in newer versions. Reopen report, when still existing.

comment:3 Changed 10 years ago by OSM@…

Resolution: fixed
Status: closedreopened

The error still exists in JOSM Version 1479. I tried to add a bus_stop to relation 79221 and got the error "412 precondition failed", but JOSM did as if everything was OK. But my changes did not got uploaded.

comment:4 Changed 9 years ago by anonymous

Ticket #1748 has been marked as a duplicate of this ticket.

comment:5 Changed 9 years ago by raffourtit@…

see also #2437 which includes a patch for a similar issue

comment:6 Changed 9 years ago by Gubaer

Cc: Gubaer added
Resolution: fixed
Status: reopenedclosed
Version: latest

JOSM version: current from SVN, 1566

Tried to reproduce the bug following the steps above. Took a long time but ultimatelly completed with ... OK.

In addition, framm has provided a fix which improves improves notification of API errors, similar but slightly different to the patch from #2437.

I therefore close this ticket. Reopen report, when still existing.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.