Modify

Opened 9 years ago

Closed 8 years ago

Last modified 4 years ago

#7713 closed defect (fixed)

false multipolygon warning on boundary relations

Reported by: skyper Owned by: team
Priority: normal Milestone: 13.11
Component: Core validator Version: tested
Keywords: relation multipolygon boundary Cc: aceman

Description

Changing a multipolygon relation in a boundary relation is not recognized in validator

  1. download a multipolygon boundary relation
  2. change its type from multipolygon to boundary
  3. add a node with role "label"
  4. upload

I get a strange warning about wrong object in multipolygon relation.

r5241

Attachments (0)

Change History (10)

comment:1 Changed 9 years ago by simon04

This is closely related to #7550.

comment:2 in reply to:  1 Changed 9 years ago by skyper

Replying to simon04:

This is closely related to #7550.

Yes, but the message is irritating as type=boundary might be a multipolygon but not a multipolygon-relation (type=multipolygon)

comment:3 Changed 8 years ago by skyper

Please, if we silently change to relation=boundary we should also make a difference in validator. I got this warning again and searched for the multipolygon to change it into a boundary only to find a correct relation=boundary.

  • There is also no hint about the relation as only a the "wrong" object is mentioned which is cumbersome if this object is incomplete. You can not select the relation nor download the incomplete node from validator toggle dialog.

comment:4 Changed 8 years ago by jjaf.de

[4219/josm] made admin_centre known to the validator-test. Now we need label at the same place otherwise a false positive of "Non-Way in multipolygon" is thrown.

comment:5 Changed 8 years ago by skyper

Ticket #9083 has been marked as a duplicate of this ticket.

comment:6 Changed 8 years ago by skyper

Cc: aceman added
Version: tested

comment:7 Changed 8 years ago by aceman

Summary: false multipolygon warningfalse multipolygon warning on boundary relations

The patch in [4219/josm] does not seem difficult to adapt. Could this be fixed for all the special member roles of boundary relation? It reports unnecessary warnings for all existing administrative boundaries in my country.

comment:8 Changed 8 years ago by stoecker

Resolution: fixed
Status: newclosed

In 6239/josm:

fix #7713 - do not warn about label role

comment:9 Changed 7 years ago by Don-vip

Milestone: 13.11 (6383)

comment:10 Changed 4 years ago by stoecker

Milestone: 13.11 (6383)13.11

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.