Modify

Opened 7 years ago

Closed 7 years ago

#7637 closed defect (fixed)

unhandled error by start after update

Reported by: Luebeck Owned by: team
Priority: major Milestone:
Component: Core Version:
Keywords: Cc:

Description (last modified by simon04)

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-04-23 01:31:02
Last Changed Author: simon04
Revision: 5204
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-04-22 11:33:19 +0200 (Sun, 22 Apr 2012)
Last Changed Rev: 5204

Identification: JOSM/1.5 (5204 de)
Memory Usage: 37 MB / 989 MB (14 MB allocated, but free)
Java version: 1.6.0_30, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows 7

Plugin: AddrInterpolation
Plugin: OpeningHoursEditor
Plugin: PicLayer
Plugin: RoadSigns
Plugin: buildings_tools
Plugin: licensechange
Plugin: measurement
Plugin: openstreetbugs
Plugin: pbf
Plugin: public_transport
Plugin: terracer
Plugin: touchscreenhelper
Plugin: turnrestrictions
Plugin: utilsplugin2
Plugin: waydownloader

java.lang.RuntimeException: java.util.concurrent.ExecutionException: java.lang.NullPointerException
	at org.openstreetmap.josm.Main.<init>(Main.java:335)
	at org.openstreetmap.josm.gui.MainApplication.<init>(MainApplication.java:66)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:270)
Caused by: java.util.concurrent.ExecutionException: java.lang.NullPointerException
	at java.util.concurrent.FutureTask$Sync.innerGet(Unknown Source)
	at java.util.concurrent.FutureTask.get(Unknown Source)
	at org.openstreetmap.josm.Main.<init>(Main.java:332)
	... 2 more
Caused by: java.lang.NullPointerException
	at org.openstreetmap.josm.gui.tagging.TaggingPreset.splitEscaped(TaggingPreset.java:953)
	at org.openstreetmap.josm.gui.tagging.TaggingPreset.access$300(TaggingPreset.java:94)
	at org.openstreetmap.josm.gui.tagging.TaggingPreset$ComboMultiSelect.initListEntriesFromAttributes(TaggingPreset.java:641)
	at org.openstreetmap.josm.gui.tagging.TaggingPreset$ComboMultiSelect.initListEntries(TaggingPreset.java:609)
	at org.openstreetmap.josm.gui.tagging.TaggingPreset$ComboMultiSelect.getValues(TaggingPreset.java:571)
	at org.openstreetmap.josm.gui.tagging.ac.AutoCompletionManager.cachePresets(AutoCompletionManager.java:156)
	at org.openstreetmap.josm.gui.preferences.map.TaggingPresetPreference.initialize(TaggingPresetPreference.java:282)
	at org.openstreetmap.josm.Main$2.call(Main.java:293)
	at org.openstreetmap.josm.Main$2.call(Main.java:286)
	at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
	at java.util.concurrent.FutureTask.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

Attachments (0)

Change History (3)

comment:1 Changed 7 years ago by simon04

Description: modified (diff)

comment:2 Changed 7 years ago by simon04

Priority: blockermajor

Are you using custom presets? If so, please list them.

The NPE comes from splitting the values (which are null) of a <combo>. As this does not occur using only the default presets and fresh preferences, I decrease the priority.

comment:3 Changed 7 years ago by simon04

Resolution: fixed
Status: newclosed

In 5208/josm:

fix #7637 - NullPointerException when parsing erroneous presets (<combo> w/o values)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.