Modify

Opened 8 years ago

Closed 7 years ago

#7620 closed defect (fixed)

JOSM crash every minute

Reported by: smarties Owned by: team
Priority: critical Milestone:
Component: Core Version:
Keywords: Cc:

Description (last modified by Don-vip)

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-04-14 14:26:11
Last Changed Author: simon04
Revision: 5181
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-04-14 12:01:16 +0200 (Sat, 14 Apr 2012)
Last Changed Rev: 5181

Identification: JOSM/1.5 (5181 de)
Memory Usage: 201 MB / 989 MB (88 MB allocated, but free)
Java version: 1.6.0_31, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows Vista

Plugin: OpeningHoursEditor (27852)
Plugin: licensechange (27964)
Plugin: measurement (27957)
Plugin: waydownloader (27852)

java.lang.NullPointerException
	at org.openstreetmap.josm.actions.mapmode.DrawAction.redrawIfRequired(DrawAction.java:153)
	at org.openstreetmap.josm.actions.mapmode.DrawAction.removeHighlighting(DrawAction.java:1056)
	at org.openstreetmap.josm.actions.mapmode.DrawAction.exitMode(DrawAction.java:232)
	at org.openstreetmap.josm.gui.MapFrame.activeLayerChange(MapFrame.java:626)
	at org.openstreetmap.josm.gui.MapView.fireActiveLayerChanged(MapView.java:141)
	at org.openstreetmap.josm.gui.MapView.setActiveLayer(MapView.java:723)
	at org.openstreetmap.josm.gui.MapView.removeLayer(MapView.java:361)
	at org.openstreetmap.josm.Main.exitJosm(Main.java:612)
	at org.openstreetmap.josm.gui.MainApplication$1.windowClosing(MainApplication.java:79)
	at java.awt.AWTEventMulticaster.windowClosing(Unknown Source)
	at java.awt.Window.processWindowEvent(Unknown Source)
	at javax.swing.JFrame.processWindowEvent(Unknown Source)
	at java.awt.Window.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$000(Unknown Source)
	at java.awt.EventQueue$1.run(Unknown Source)
	at java.awt.EventQueue$1.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$2.run(Unknown Source)
	at java.awt.EventQueue$2.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (4)

comment:1 Changed 8 years ago by Don-vip

Description: modified (diff)

comment:2 Changed 8 years ago by Don-vip

Does it occur only when you're closing JOSM ?

comment:3 Changed 8 years ago by simon04

Ticket #7622 has been marked as a duplicate of this ticket.

comment:4 Changed 7 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 5223/josm:

should fix #7620 - NPE in unknown conditions (not reproduced)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.