Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#7609 closed defect (duplicate)

Replace Geometry command hangs josm with 100% cpu

Reported by: Cobra Owned by: team
Priority: critical Milestone:
Component: Plugin utilsplugin2 Version: latest
Keywords: Cc:

Description

When replacing the geometry of a certain object, josm hangs (forever? at least a very, very long time) with 100% cpu load.

How to reproduce:

  1. open attached file
  2. select the buildings with the name "replace me", "with this"
  3. More Tools -> Replace Geometry
  4. confirm conflict
  5. josm hangs

This happens also when the new way ("with this") is untagged. This was only done to simplify dubugging.

Attachments (1)

7609.osm (171.7 KB) - added by Cobra 10 years ago.

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by Cobra

Attachment: 7609.osm added

comment:1 Changed 10 years ago by Cobra

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-04-13 18:49:27
Last Changed Author: simon04
Revision: 5180
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-04-12 14:11:07 +0200 (Thu, 12 Apr 2012)
Last Changed Rev: 5180

Identification: JOSM/1.5 (5180 en)
Memory Usage: 581 MB / 910 MB (383 MB allocated, but free)
Java version: 1.6.0_31, Sun Microsystems Inc., Java HotSpot(TM) 64-Bit Server VM
Operating system: Linux
Dataset consistency test: No problems found

Plugin: FastDraw (28167)
Plugin: FixAddresses (27907)
Plugin: HouseNumberTaggingTool (27865)
Plugin: ImportImagePlugin (27906)
Plugin: InfoMode (27981)
Plugin: PicLayer (27883)
Plugin: alignways (27852)
Plugin: buildings_tools (27984)
Plugin: contourmerge (1003)
Plugin: licensechange (27964)
Plugin: measurement (27957)
Plugin: mirrored_download (28108)
Plugin: openstreetbugs (27852)
Plugin: openvisible (27852)
Plugin: pbf (27649)
Plugin: pdfimport (27867)
Plugin: proj4j (27902)
Plugin: restart (27852)
Plugin: reverter (28089)
Plugin: terracer (27852)
Plugin: undelete (27852)
Plugin: utilsplugin2 (28222)

comment:2 Changed 10 years ago by rickmastfan67

Resolution: duplicate
Status: newclosed

Closed as duplicate of #7295.

-----

joshdoe has been working on cleaning up stuff like this in #7295. So, you should comment in that ticket instead. ;)

Last edited 10 years ago by rickmastfan67 (previous) (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.