Modify

Opened 8 years ago

Closed 8 years ago

#7567 closed defect (duplicate)

Encoding error when clicking on a way

Reported by: The RedBurn Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Download http://download-int.geofabrik.de/osm/europe/belgium.osm.pbf
  2. Use osmconvert to reduce the size (to minlat="50.5337872" minlon="5.8581965" maxlat="50.5397112" maxlon="5.8753645")
  3. Click on the way near 50.53784, 5.8716

What is the expected result?

  • Show the way infos

What happens instead?

  • An encoding error dialog shows up.

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-03-07 02:32:17
Last Changed Author: stoecker
Revision: 5047
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-03-06 10:30:34 +0100 (Tue, 06 Mar 2012)
Last Changed Rev: 5047

Identification: JOSM/1.5 (5047 fr)
Memory Usage: 95 MB / 247 MB (47 MB allocated, but free)
Java version: 1.6.0_29, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows XP
Dataset consistency test: No problems found

Plugin: pbf (27649)

java.lang.NullPointerException
	at org.openstreetmap.josm.data.coor.LatLon.greatCircleDistance(LatLon.java:199)
	at org.openstreetmap.josm.data.osm.Way.getLength(Way.java:579)
	at org.openstreetmap.josm.gui.dialogs.SelectionListDialog$SelectionListModel.setJOSMSelection(SelectionListDialog.java:593)
	at org.openstreetmap.josm.gui.dialogs.SelectionListDialog$SelectionListModel.selectionChanged(SelectionListDialog.java:672)
	at org.openstreetmap.josm.data.osm.event.SelectionEventManager.fireEvents(SelectionEventManager.java:78)
	at org.openstreetmap.josm.data.osm.event.SelectionEventManager.access$200(SelectionEventManager.java:20)
	at org.openstreetmap.josm.data.osm.event.SelectionEventManager$1.run(SelectionEventManager.java:85)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$000(Unknown Source)
	at java.awt.EventQueue$1.run(Unknown Source)

Attachments (2)

error screenshot.jpg (385.5 KB) - added by The RedBurn 8 years ago.
encoding error screenshot
7567.osm.bz2 (16.3 KB) - added by simon04 8 years ago.

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by The RedBurn

Attachment: error screenshot.jpg added

encoding error screenshot

Changed 8 years ago by simon04

Attachment: 7567.osm.bz2 added

comment:1 Changed 8 years ago by simon04

Result after 2. is attached as 7567.osm.bz2. The first node (id 326106266) of way 44681716 is missing in the output of osmconvert and therefore gives rise to this NullPointerException.

comment:2 Changed 8 years ago by Don-vip

In 5187/josm:

see #7567 - fix NPE with ways with incomplete nodes.

comment:3 Changed 8 years ago by Don-vip

The NPE is fixed, but we need to deal with incomplete ways when opening such files. JOSM already detects them, as shown on the standard output:

Le chemin 37 601 755 avec 3 nœuds a des nœuds incomplets car au moins un nœud était manquant dans les données chargées.
...
Le chemin 137 002 879 avec 23 nœuds a des nœuds incomplets car au moins un nœud était manquant dans les données chargées.

I think we should ask to the user if he wants to download incomplete nodes when the file has been loaded.

comment:4 Changed 8 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #6761.
By the way we were already talking about it in #6761, see this ticket for the next discussions.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.