Modify

Opened 8 years ago

Closed 8 years ago

#7546 closed defect (fixed)

False positive The "to" way does not start or end at a "via" node

Reported by: Paultergeist Owned by: team
Priority: normal Milestone:
Component: Core validator Version: latest
Keywords: validator restriction relation Cc:

Description

Relation that produces false positive

Reproduced on both tested (r5047) and latest (r5115) versions.

Attachments (1)

7546.patch (6.2 KB) - added by simon04 8 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 8 years ago by simon04

This behavior is not intended. However, why is this turn restriction necessary at all (the to way is a oneway)?

Changed 8 years ago by simon04

Attachment: 7546.patch added

comment:2 Changed 8 years ago by simon04

Patch adds warning Superfluous turnrestriction as "to" way is oneway and therefore fixes this bug. Any comments?

comment:3 in reply to:  1 Changed 8 years ago by Paultergeist

Looks like it is really not necessary any more. According to the history when the relation was created, the to way was not oneway.

Thanks for the patch, having this warning is great.

comment:4 Changed 8 years ago by simon04

Resolution: fixed
Status: newclosed

In 5199/josm:

fix #7546 - add validation warning Superfluous turnrestriction as "to" way is oneway

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.