Modify

Opened 8 years ago

Closed 7 years ago

#7458 closed enhancement (fixed)

Create multipolygon function: enable tags moving

Reported by: akks Owned by: team
Priority: major Milestone:
Component: Core Version: latest
Keywords: multipolygon Cc: Zverikk

Description (last modified by akks)

We have "create multipolygon" function in core but it does not add any tags to multipolygon and is inconvenient comparing to plugins.

Most functional plugin for relations is Zverik's Reltoolbox. Its multipolygon creation function is flexible and convenient.

I was asked at the forum to add tag moving functionality to standard action. I extracted tag changing function from Zverikk's action (which was long time ago copied from removeTagsFromInnerWays and improved), leaving all advanced functionality (boundary management, multiple rings) only in plugin. Author approved the idea.

Here is the patch to review and compiled vesrion on DropBox to test:
http://dl.dropbox.com/u/63393258/josm-custom-createrelation.jar

Attachments (1)

CreateMultipolygonAction.java.patch (5.6 KB) - added by akks 8 years ago.

Download all attachments as: .zip

Change History (10)

Changed 8 years ago by akks

comment:1 Changed 8 years ago by akks

Description: modified (diff)

comment:2 Changed 8 years ago by Zverikk

You just copypasted the code. It can be simplified, also removing dependencies from reltoolbox plugin. First of all, delete everything related to boundaries. Consider isBoundary = false, moveTags = true, and remove corresponding ifs.

comment:3 Changed 8 years ago by akks

I was asked to do copy-paste - I did it) All other functions are from core action, not from plugin.

Dependencies were removed, I was writing the post to ask about isBoundary on the forum while receiving this message.

I think we should leave some advanced parameters like moveTags and lineartagstokeep for those who prefer old behaviour or want some customization.

It would be better if you remove boundary-specific lines yourself - the problem is that standard action should work correctly for boundary relations too, not breaking them at least.

Last edited 8 years ago by akks (previous) (diff)

comment:4 Changed 7 years ago by skyper

Priority: normalmajor

Please move the tags from the way to the relations.

The behaviour right now is depreciated.

Thanks

comment:5 Changed 7 years ago by bastiK

@akks: can you do this?

comment:6 Changed 7 years ago by akks

In 5225/josm:

see #7458 : enable tags moving when creating multipolygon [improved code from Zverik's Relation Toolbox plugin copied back to core ]

comment:7 Changed 7 years ago by akks

I removed all boundary-related functionality reatining configuration parameters multipoly.movetags and multipoly.lineartagstokeep before commiting.

@Zverikk, @team: Please check the code and updated work of Ctrl-Alt-A.

Do we need more extensions in core creating mutipolygon functionality?

Last edited 7 years ago by akks (previous) (diff)

comment:8 Changed 7 years ago by akks

Can we close the ticket?

Last edited 7 years ago by akks (previous) (diff)

comment:9 Changed 7 years ago by akks

Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.